Removing OnOff capability from dimmer switches or something better (Homekit ON/level race)

Since Homekit doesn’t send ordered commands for dimmable lights using Siri to set absolute brightness/dim levels results in random brightness of 100. The “ON” sometimes gets sent after the value. For example “Siri, set kitchen lights 15%”:

19:25:06.131 [INFO ] [smarthome.event.ItemCommandEvent    ] - Item 'Kitchen_Dimmer' received command 15   
19:25:06.146 [INFO ] [smarthome.event.ItemCommandEvent    ] - Item 'Kitchen_Dimmer' received command ON
19:25:06.165 [INFO ] [marthome.event.ItemStateChangedEvent] - Kitchen_Dimmer changed from 12 to 15
19:25:06.175 [INFO ] [marthome.event.ItemStateChangedEvent] - Kitchen_Dimmer changed from 15 to 100

**Workaround:** I haven't found a good solution to this problem, however I now have a rough workaround given that I'm still new to OH2. The only thing I've got working is to remove the binding of the OnOff type in for the Thing properties:
"binding:Command:OnOffType": "SWITCH_MULTILEVEL,BASIC",

This of course results in some warnings about missing channels in the logs:

21:30:30.612 [WARN ] [ding.zwave.handler.ZWaveThingHandler] - NODE 14: Command for unknown channel zwave:device:bd2f8333:node14:switch_dimmer with OnOffType

**Proper solution:** I know the workaround is a dirty fix and a more proper/clean solution is the thing I'm looking for. I'm pretty clueless where to go from here. I've searched the forums for filtering commands (seems unlikely?). I've seen other implementations adding delays to the commands in order to prevent the race, but haven't changed any lines of code in the homekit addon.

What are my best options here and what would the collective intelligence here on the forum advice me to do?