Repeated errors logging on to Xiaomi cloud

I have all the sudden lost connection to my Roborock vacuum cleaner. In the logs I see the following

[INFO ] [] - Repeated errors logging on to Xiaomi cloud. Cleaning stored cookies

I have tried to restart but the connection won’t reconnect.

I get the same error message, using the DE and CN servers, Binding and OH both Version 3.2
They might have changed something in the backend :-/

Same is indeed reported in several topics.
I expect something has changed in the backend as there was no change in the binding in that area in the binding for some time.

As I’m away from home this week, it may take a while before I can take a deeper look at the issue.

Yup either this or the fact that the servers went down on 31st Dec messed something in the binding up while it kept retrying for many many hours. I doubt they ran a big update on New Years Eve, but who knows.

I was able to load a fresh instance of oh3.2 and was able to logon to the cloud as usual, and receive a fresh map from my vacuum.

So,I’m hopefull that if you restart openhab (which will for sure clear al cookies/old login info etc), you should be able to get new data. If a device has wrong token and it is not automatically refreshed, you may try to clean the token field.

Let me know if that solves the issue. I prob need to improve the handling of changing tokens

Sorry I forgot to report that it start working yesterday morning without any restart or changes from myside.