Repository at down?


I’m having some trouble with IDE setup. After a fresh install using Eclipse Installer and the openHAB 2 Add-ons project, I’m getting errors all over (over 14000), and the following errors in the Target Platform, which I think may be the cause:

The repository at gives a 404 error.

I’m using OpenJDK 9, but also tried with 8.This test was done with Neon. I’m unable to try again with Mars, the installer seems to be stuck

I hope someone can help.

Works fine on Mars. Sorry for the noise.


I am trying to install the openHAB2 IDE using Eclipse Installer and the instructions found here: However, I get the exact same error as @fa2k and cannot find a way around the problem. Since the Eclipse Installer selects Eclipse Neon for installation, it should work with that version, right?

I you look at the directory listing in, you may notice that there is no context.xml, and no other xml file for that matter (should there be a site.xml?).

What should I do now?

I’m answering this myself, since I have solved the problem now. Well, “solved” may not be the best word. I ended up reinstalling Ubuntu completely and then the Eclipse Installer and the Target Definition magically started working…