Reset My ZWave Controller and Now I Can't Add Devices

I have a RPi 3 and a Aeotec Gen5 ZWave USB controller. I am running Openhabian with Openhab 3.1. The ZWave controller shows that it is online but when I click Scan and put any of my devices into discovery mode it never detects anything.

Originally, I set it up with Openhab 2.5 using Openhabian several years ago so I don’t remember if I had to do anything extra to get this to work. But, it was working fine on 2.5. I decided to do a fresh install of the latest version Openhabian in order to upgrade to Openhab 3.1. Everything was working fine except that all of my ZWave devices were detected at the same time because they were still in the controller’s memory. I didn’t know which was which and the names weren’t all correct. So, I removed everything in Openhab and then pulled the ZWave stick out and pushed the small button with a pen to do a full reset of the controller. I thought then I could add my devices one by one but now they aren’t detected. I tried to once again do a fresh install of Openhabian thinking I messed up something in the settings but that hasn’t helped. It seems there is something wrong with the controller when I did the full factory reset. Does anyone have any ideas for how to fix this?

I set the serial controller port to: /dev/ttyACM0

2021-10-20 14:08:58.819 [INFO ] [zwave.handler.ZWaveControllerHandler] - Attempting to add listener when controller is null
2021-10-20 14:09:03.992 [INFO ] [ve.internal.protocol.ZWaveController] - Starting ZWave controller
2021-10-20 14:09:03.994 [INFO ] [ve.internal.protocol.ZWaveController] - ZWave timeout is set to 5000ms. Soft reset is false.

Events log:

2021-10-20 14:08:58.851 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'zwave:serial_zstick:814c0b8381' changed from UNINITIALIZED to INITIALIZING
2021-10-20 14:08:58.905 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'zwave:serial_zstick:814c0b8381' changed from INITIALIZING to OFFLINE (BRIDGE_OFFLINE): Controller is offline
2021-10-20 14:09:07.521 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'zwave:serial_zstick:814c0b8381' changed from OFFLINE (BRIDGE_OFFLINE): Controller is offline to ONLINE

I haven’t seen any error messages.

The factory reset cleares the internal memory of the controller as well, so i’m afraid you need to include your devices again.

I would assume that the ZWave devices’ end is still paired with the controller and you need to factory reset them as well. Have you tried that ?

Wow, I spent hours reading forums and messing with the settings. I didn’t know you had to reset the devices too. That worked! Thank you!