RESOL vbus channels not updated

Hello RESOL vbus Users,
allow me another trial. As I got absolutely no reply, I suppose having posted the topic under ‘Hardware/Home Automation’ was not a good choice. Being a beginner, I also would appreciate to get advice where better to place such a topic. Thus once again:

I’ve successfully installed vBus LAN Adater Bridge and the link to the DELTASOL M Device via DL2 Data Logger - all ONLINE, everything seems to work fine, BUT I only receive channel values captured e.g. at the reboot, no update, no error message in the log files. What I’m doing wrong?

Thx for your ideas in advance!

Hello Michael
I am using this binding since more than a year without troubles.
There was a little problem some time ago:
But this should have been solved.
On which version of OH are you?

To be able to help you, it would be helpful to know a little more about your configuration.
Do you use files or the UI?

Hello Christian, hello Tallman,
thx for your reply. Good to hear that it is possible to get it running. I’m working with OH 3 on a Raspberry Pi 4 B / openHABian 3.1.0 - so far by UI only. Persistence settings are as per the standard installation (RRD4j - DB).

MQTT related things and items are working fine. All vBus related things continuously reporting ‘ONLINE’. However I’m receiving actual values from the RESOL vBus only when restarting the Pi or changing e.g. the ‘refreshInterval’ RESOL vBus LAN Adapter (Bridge) , which will be shown until the next restarting / settings update.

No conspicuous messages re vBus in any of the log-files. Should I set-up a specific persistence rule?

You should have a VBus LAN adapter with something like this

UID: resol:vbuslan:bridge
label: VBusLAN Adapter
thingTypeUID: resol:vbuslan
  password: xxxx
  adapterSerial: xxxxxxxxxx
  port: 7053
  refreshInterval: 600

and a device, e.g. this one

UID: resol:device:bridge:DeltaSol_BS_DrainBack
label: DeltaSol_BS_DrainBack
thingTypeUID: resol:device
configuration: {}
bridgeUID: resol:vbuslan:bridge

Yes, that is how it is looking in my configuration as well - of course with other labels - thank you for sharing. … and basically it seems to work, I’m getting the data, but only once …
Did you work with the standard persistence model?

I assume you have no active connection to or opening the port in your browser?
Vbus allows just one connection, but you should see that as the bridge would switch then between online / offline continuously.

Just recognized that you mentioned the persistance, I hope you do not persist on “every change” as vbus is flooding data …

Whether OH receives data initially has nothing to do with persistence.
If you have installed the Device Discovery Tool, you can see whether the Resol-Lan Adapter is continuously receiving data.

Thank you Tallman, i.e. we can exclude persistence issues. The vBus is alive. I can continuously monitor the sensor and controler data via the web interface of the DL2.

@Michael: Here you got a point. In the event.log file I see this toggling only when restarting the Pi or changing e.g. the ‘refreshInterval’ RESOL vBus LAN Adapter (Bridge):

2021-12-08 09:21:12.450 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'resol:device:RESOL-VBusLAN-Adapter-Thing:DeltaSol_M-Controller' changed from UNINITIALIZED to INITIALIZING
2021-12-08 09:21:12.460 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'resol:device:RESOL-VBusLAN-Adapter-Thing:DeltaSol_M-Controller' changed from INITIALIZING to ONLINE
2021-12-08 09:22:17.050 [INFO ] [openhab.event.ItemStateChangedEvent ] - Item 'DeltaSolMRegler_TemperaturSensor2' changed from NULL to 33.7 °C
2021-12-08 09:25:47.650 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'resol:vbuslan:RESOL-VBusLAN-Adapter-Thing' changed from ONLINE to OFFLINE (COMMUNICATION_ERROR): TCP connection failed: DISCONNECTED
2021-12-08 09:25:47.653 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'resol:vbuslan:RESOL-VBusLAN-Adapter-Thing' changed from ONLINE to OFFLINE (COMMUNICATION_ERROR): TCP connection failed: DISCONNECTED
2021-12-08 09:25:47.657 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'resol:device:RESOL-VBusLAN-Adapter-Thing:DeltaSol_M-Controller' changed from ONLINE to OFFLINE (BRIDGE_OFFLINE)
2021-12-08 09:25:47.745 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'resol:vbuslan:RESOL-VBusLAN-Adapter-Thing' changed from OFFLINE (COMMUNICATION_ERROR): TCP connection failed: DISCONNECTED to OFFLINE (COMMUNICATION_ERROR): TCP connection failed: CONNECTING
2021-12-08 09:25:47.759 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'resol:vbuslan:RESOL-VBusLAN-Adapter-Thing' changed from OFFLINE (COMMUNICATION_ERROR): TCP connection failed: CONNECTING to ONLINE
2021-12-08 09:25:47.763 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'resol:device:RESOL-VBusLAN-Adapter-Thing:DeltaSol_M-Controller' changed from OFFLINE (BRIDGE_OFFLINE) to ONLINE
2021-12-08 09:25:48.167 [INFO ] [openhab.event.ItemStateChangedEvent ] - Item 'DeltaSolMRegler_TemperaturSensor2' changed from 33.7 °C to 36.7 °C

I found a solution, most probably a workaround. @Christian (erroneously mixed up with ‘Michael’ - sorry) you provided the idea: Using a cron triggered rule I’m now switching the bridge off and on:

rule “Refresh_RESOL-Bridge”

Time cron “0/30 * * ? * * *”
sendHttpPutRequest(“http://mylogin:mypwd@myPi-IP:8080/rest/things/resol:vbuslan:RESOL-VBusLAN-Adapter-Thing/enable”, “application/json”, ‘false’)
sendHttpPutRequest("(“http://mylogin:mypwd@myPi-IP:8080/rest/things/resol:vbuslan:RESOL-VBusLAN-Adapter-Thing/enable”, “application/json”, ‘true’)

REMARK: My password contained a ‘?’, which caused some trouble. Selecting a password without special character and creating a new token accordingly solved that issue.

Sorry, that I did not respond so long :frowning:

@danielwippermann do you have any idea for something that could stop the data stream from the DL2 to the vbus-java library with a “TCP connection failed: DISCONNECTED”?

@mischmi as mentioned by someone above the resol devices support only one TCP connection at a time, so in case you have anything else connecting to the DL2 it could stop talking to your openhab (e.g. the ResolServiceCenter software), but normally the binding should try to reconnect and at least yield toggeling the thing status between ONLINE and OFFLINE. The same happens if the openHAB instances are using it, or maybe it could be possible to add two bridge devices with the same IP address within one openHAB. Did you check that?

Hi all!

@danielwippermann do you have any idea for something that could stop the data stream from the DL2 to the vbus-java library with a “TCP connection failed: DISCONNECTED”?

No, the explanation you gave would have been my only guess as well.

Just some clarification: the DL2 is not the only limited to one TCP connection at a time. Only the VBus/LAN adapter has this limitation. DL2, DL3, KM1 and KM2 support up to 10 concurrent connections. But as far as I understand Michael uses a VBus/LAN adapter so your explanation still fits :slight_smile:

Stay safe and healthy, Daniel

1 Like

Same problem here…

I have used the older Resol Binding on openhab 2.6 this version worked properly.

I am using Openhab 3.4.0M3 with the Resol VLan adapter. My Device on the VBUS is a SLR (0x7331 SLR) from Citrinsolar.

I think this is a common problem New RESOL binding in OH3.3 does not work with device KM1 · Issue #13447 · openhab/openhab-addons · GitHub

How can i help and debug the problem?

I have started the issue on github mentioned by urlacher23.
The problem still persists, even after installing openhab 3.3 on a fresh SD card with latest bullseye system and setting up the binding from the scratch.
The binding can set up a brdige (VBusLAN adapter) and detects my KM1 as SKR 1/2/3, all channels are updated once after initialization, then never again. An update can be initiated if the bridge is stopped and started again.
Please let me know if there is more information needed to solve the issue.
I would appreciate any help.

During the development I have similar behavior several times but since ‘years’ it’s running without any issue. Can you try to configure the plugin to log trace messages, restart openHAB an paste the relates logs here or in the GitHub ticket?

I guess you don’t have another device in your network accessing the VBUS-Adapter?

Did you try to reset the VBUS adapter?

I have done resets and fresh setups over and over. There is no other device in the network using VBus.
I have configured the log as proposed (see the github ticket), but there are no relevant entries.
Please let me know if I can do anything else to track down this issue.

One issue showing the behavior described in this thread was related to controllers transmitting a time channel including the weekday is solved: [resol] New binding in OH3.3 does not work with device SKSR 1/2/3 · Issue #13447 · openhab/openhab-addons · GitHub

Would be great if you’d test it with the jar that is linked there. In case there are other situations showing this behavior, feel free to create a ticket on github and provide more details - ideally with temporary exposing your vbus-port to the internet and sharing the details with me privately - then I can debug the issue from my side.

As the used resol-java-vbus library supports a giant amount of resol controller the binding theoretically also supports them, but as most of them are untested there could be some smaller issues.