[Resolved] Cron Job Expression for specific Day not triggering

  • Platform information:
    • Hardware: Synlogy NAS
    • OS: Docker
    • Java Runtime Environment: Docker Java 11
    • openHAB version: 3.2.0

I build up a simple rule with cron expression via the cron builder, it looked like:

configuration: {}
  - id: "1"
      cronExpression: 0 0 12 ? * MON,FRI *
    type: timer.GenericCronTrigger
conditions: []
  - inputs: {}
    id: "2"
      considerConditions: true
        - 1c289eab04
    type: core.RunRuleAction

I wondered why it wasn’t triggered, so i suspected a failure in the rule itself and triggered manually. No problem so far. Then i played around with the cron expression and found out, it has something to do with the days, an expression triggering every day works without problems.

I looked up the quartz docu for any hint and also tried with a number, thought maybe its a locale issue, but that did not work either.

Expression: 0 37 12 ? * 6

Is there anything i can debug any further or turn on logging to see what goes wrong?
Or am i missing something crucial ?



kick me in the nuts, today is thursday OMG facepalm
but day naming still not working, numbers yes

the initial rule hat problems executing, the cron day expression was working correctly.
it was me who was wrong, as i thought i am on friday already :confused: