[Resolved] Google Nest Binding Setup Not Working

I’ve run into some error setting up the Nest Binding with an SDM Account. I was able to get access to the SDM API, and create a project in the Device Access Console, so I should have all the IDs necessary (Client ID, Project ID, etc.) However, the Binding Setup page has a link to follow in order to get an Authorization Code:


I get the error “redirect_uri_mismatch”.

Also, the “Create Thing” button isn’t responding to try and create the Thing anyway with the rest of the project information. I hope that the binding creation is sanity checking the inputs, but is the Binding broken? I’m on OpenHAB 4.0.2.

Did you replace {{ProjectID}} and {{ClientID}} with your values without the {{ }}.

Yes, I did. I’ve spent the afternoon digging into the URI mismatch error, and I found a few issues that I changed to get past. For one, my primary google account is a GoogleApps account, which has all kinds of compatibility issues with Nest, so I created a new Google developer account and Web Project with a “regular” Google account. I also had to create a Redirect URI in that Google Developer Web Project, and replace that in the redirect_uri parameter. Eventually, I got both Authorization Codes for the Nest SDM Binding.

However, I still can’t click on the “Create Thing” button on the bottom. This must not be a Nest Binding issue, I tried another binding and it won’t create things either…

[UPDATE] I rebooted and everything is fine. Weird.

[SECOND UPDATE] In case anyone runs into this kind of error. I created a redirect_uri parameter previously, but I had erroneously assumed it needed to point to my Google Apps domain, which was wrong. The instructions for created an OAuth 2.0 Client ID in the Google Credentials is pretty clear about adding https://www.google.com as the redirect_uri, but I had previously generated those credentials for something else, and missed it this time around.

[FINAL UPDATE] I thought I could skip a few steps in the Nest Binding documentation since I already had developer projects and OAuth accounts. I should not have. RTFM. It all works great!

So I’m trying to set this up and getting the same error you mentioned. I found this in googling around for answers. Wondering if you could outline what steps you missed maybe? I’ve tried doing this probably 15x trying to read every word in the Nest Binding documentation as you suggested but I’m still getting the “redirect_uri_mismatch” error. I can’t figure out what I might be missing!

The “redirect_uri_mismatch” error is likely because something is wrong with the allowed URIs for the credentials.

Double-check that the Authorized redirect URIs include “https://www.google.com