Resources missing in REST API


We are using OpenHAB2 and developing some bindings. After syncing the newest commits from upstream just now – last update was from since about May – we are having the following problem: many resources (items, things…) are missing from the REST API. The paper UI reports 404 errors. The API page looks like this:

We get this error in console:
2016-07-09 19:48:20.966 [DEBUG] [r.JSONResponse$ExceptionMapper:158 ] - exception during REST HTTP 404 Not Found
at org.glassfish.jersey.server.ServerRuntime$
at org.glassfish.jersey.internal.Errors$
at org.glassfish.jersey.internal.Errors$
at org.glassfish.jersey.internal.Errors.process(
at org.glassfish.jersey.internal.Errors.process(
at org.glassfish.jersey.internal.Errors.process(
at org.glassfish.jersey.process.internal.RequestScope.runInScope(
at org.glassfish.jersey.server.ServerRuntime.process(
at org.glassfish.jersey.server.ApplicationHandler.handle(
at org.glassfish.jersey.servlet.WebComponent.serviceImpl(
at org.glassfish.jersey.servlet.WebComponent.service(

This is probably in Eclipse SmartHome, but I|m not sure how to proceed with troubleshooting. Any tips?

We tried to reinstall the entire IDE.

I assume this is within the IDE only or also in the distro?

Sounds to me as if the mapdb bundle is not available.
I have just created, so please pull this change and see if it makes a difference.

Yes! That solved it. Thanks.:slight_smile: