Restore Bindings from backup not working

  • Platform information:
    • RPI3+

    • OS: Raspbian 5.4.35-v7+

    • openHAB version: 3.1.0

I took a backup after finish migration from 2.7 to 3.1
Today i lost all my installed bindings after install a Denon/Marantz binding and tried to use the restore function to get state before but after restore, bindings are still not showing up.

What’s wrong? Atm. i try to install all the bindings again

EDIT: I also lost all transform components

Do you mean 2.5.7 perhaps? There never was an OH 2.7.

What do you see in the logs?

Took a backup how?

Did a restore how?

i thought it was 2.7 but i did check out the backup file and this was made with 2.5.12.
Everything was working in 3.1 and i did make a backup in 3.1.0 with openhab-cli backup and /openhab/runtime/bin/backup
There was no errors during backup and restore but i didn’t check the logfiles.
i tried the restore over openhab-cli restore.

Which backup did you try to restore? The 2.5.12 backup won’t work on OH 3.1.

When something doesn’t work you must always look in the log files. That’s where you get information about what is wrong.

I did make a backup in 3.1.0 and tried to restore it. Where i can find the additional restore logs? i have to stop openhab service before i can restore the backup.

Not restore logs. openhab.log when it tries to start up. There are probably errors being written to that log. What are they?

I don’t have this logs anymore. i will check it out on next restore.

openHAB is not working now, correct? When openHAB is not working, almost 100% of the time it will complain right now in openhab.log about what is wrong. I don’t care what the logs were when you did the restore. I care about the errors that are happening right now.

1 Like

OpenHab is working well yet after i did restore the missing bindings and components manually.
I can try it again but i would make a snapshot before