RFLink binding not working in fresh openhab 2.4.1 install


I am using openhab 2.4.1 on a RPi3, and i get the following message in the “events.log” file while using the RFLink binding ( https://github.com/cyrilcc/org.openhab.binding.rflink ):


This is the content of my “openhab.log” file after restarting openhab2 (and having DEBUG enabled for rflink addon: log:set DEBUG org.openhab.binding.rflink):

2019-12-18 10:08:49.598 [DEBUG] [org.openhab.binding.rflink          ] - BundleEvent [unknown:512] - org.openhab.binding.rflink
2019-12-18 10:08:49.674 [DEBUG] [org.openhab.binding.rflink          ] - ServiceEvent REGISTERED - {org.eclipse.smarthome.core.thing.binding.ThingHandlerFactory}={service.id=120, service.bundleid=198, service.scope=bundle, component.name=org.openhab.binding.rflink.internal.RfLinkHandlerFactory, component.id=12} - org.openhab.binding.rflink
2019-12-18 10:08:49.685 [DEBUG] [org.openhab.binding.rflink          ] - BundleEvent STARTING - org.openhab.binding.rflink
2019-12-18 10:08:49.689 [DEBUG] [org.openhab.binding.rflink          ] - BundleEvent STARTED - org.openhab.binding.rflink
2019-12-18 10:08:51.871 [INFO ] [panel.internal.HABPanelDashboardTile] - Started HABPanel at /habpanel
2019-12-18 10:08:52.210 [INFO ] [ebuilder.internal.HomeBuilderServlet] - Started Home Builder at /homebuilder
2019-12-18 10:09:04.558 [INFO ] [thome.model.lsp.internal.ModelServer] - Started Language Server Protocol (LSP) service on port 5007
2019-12-18 10:09:06.494 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'rflink.things'
2019-12-18 10:09:06.879 [DEBUG] [rflink.internal.RfLinkHandlerFactory] - RfLinkHandlerFactory createHandler(rflink:bridge:usb0)
2019-12-18 10:09:06.903 [DEBUG] [org.openhab.binding.rflink          ] - ServiceEvent REGISTERED - {org.eclipse.smarthome.config.discovery.DiscoveryService}={service.id=294, service.bundleid=198, service.scope=singleton} - org.openhab.binding.rflink
2019-12-18 10:09:07.776 [INFO ] [.dashboard.internal.DashboardService] - Started Dashboard at
2019-12-18 10:09:07.779 [INFO ] [.dashboard.internal.DashboardService] - Started Dashboard at
2019-12-18 10:09:08.292 [INFO ] [arthome.ui.paper.internal.PaperUIApp] - Started Paper UI at /paperui

This is the content of my .things file

Bridge rflink:bridge:usb0 [ serialPort="/dev/ttyACM0", baudRate=57600 ] {
    energy myEnergy [ deviceId="OregonCM119-0004" ]

I am able to “cat” “/dev/ttyACM0” so my rflink is working.

But I am not able to see any device on discovery.

I have already issued the following command on the openhab console:

feature:install openhab-transport-serial

Do I need to do something else?
Thanks in advance!

Try upgrading to 2.5 which was released last Sunday. 2.4 is a year old.

I recommend to upgrade as 2.5 is now the latest stable version.

It’s not a binding part of the official distribution and from the link provided the binding doesn’t seem to be updated lately specific for newer versions. So I don’t see why upgrading to 2.5 will help solve this issue.

The state change isn’t something done by the binding but by openHAB, which could mean some configuration problem or the binding can’t be loaded correctly. If it’s the first case check your configuration. If it’s the second case it might just be this version of the binding is not compatible with 2.4.1 and a developer of the binding might be able to help. (I see you already logged an issue on the binding github page, so hopefully you get some feedback there)

1 Like

Finally I solved it. I do not know why but defining the thing manualy (.thing file) was not working. Using discovery feature instead worked. So i plan to use Paper UI for things and all the other configurations in files.