RFLink binding

I’m using the rflink binding for my battery powered shutters. The motor used is a BREL MLE25-1.1
They are working fine with the binding except for 1 thing. These battery devices go into some sort of sleeping mode after using them not for a while. When they are in sleeping mode I have to send multiple commands for waking them up. then they behave like normal. I have the same issue with the included remote. I’m trying to write a rule that wakes them up before using, but don’t have success till now. The wake up is not reliable. Anybody had the same problems and a good solution ?

Just updated to openhab 4 and this binding doesnt seem to work. Wondering if anyone else has got it working yet?

Edit: Apologies… it still works. Had to re-install dependencies.

1 Like

Hi! It’s cool! where can I watch and download? (for v4.0.4)!


I used this RFLink binding with OH3. But now I updated to v4.0.4. Is there a OH4 version of this RFLink binding ?


1 Like

Sorry, but what do you mean by dependencies?

Hi Phil,

I managed to update my RFLink binding to the latest OH3 update by installing the commons-io-2.8.0.jar dependency in the /usr/share/openhab/addons folder

But now I try to redo this installation under OH 4.0.4, but without success. Here I installed the package org.openhab.binding.rflink-3.1.0-SNAPSHOT.jar

I no longer have any errors in the log, but on the GUI I can’t find this binding ! How do you access the bindings installed in the addons folder ?


Thanks for the reaction!
Excuse me for my english language because i speak dutch (belgian)

For me just the same problem in OH4:

  • OH3 worked fine

  • OH4 (last week updated to 4.04 over 4.03) no more any connection over rflink

  • in my installation:

  • in bundle:list 336 │ Installed │ 80 │ │ openHAB Add-ons :: Bundles :: RfLink Binding

  • but i do not see the binding

  • id do not see any thing

  • in the event log: i see no problems:

  • 2023-11-20 10:52:28.228 [INFO ] [openhab.event.ItemCommandEvent ] - Item ‘StoreKleinShutter’ received command DOWN

    2023-11-20 10:52:28.237 [INFO ] [penhab.event.ItemStatePredictedEvent] - Item 'StoreKleinShutter' predicted to become NULL
    2023-11-20 10:52:29.255 [INFO ] [openhab.event.ItemCommandEvent ] - Item 'StoreKleinShutter' received command UP
    2023-11-20 10:52:29.256 [INFO ] [penhab.event.ItemStatePredictedEvent] - Item 'StoreKleinShutter' predicted to become NULL
    2023-11-20 10:52:30.037 [INFO ] [openhab.event.ItemCommandEvent ] - Item 'StoreKleinShutter' received command STOP- from OH2 i use text definitions:
  • for rflink:

  • Bridge rflink:bridge:usb0 “RfLink USB Transceiver” @ “Keukenberging” [baudRate= 57600, serialPort= “/dev/ttyACM0”, disableDiscovery= true, keepAlivePeriod= 55 ]

  • Thing rts RTS-6A643D-01 “Store Klein” (rflink:bridge:usb0) @ “Eetkamer” [ deviceId=“RTS-6A643D-00”, shutterDuration= 70]

  • Switch StoreKleinCommand “StoreKleinC” {channel=“rflink:rts:usb0:RTS-6A643D-00:command”}
    Rollershutter StoreKleinShutter “StoreKleinS” {channel=“rflink:rts:usb0:RTS-6A643D-00:shutter”}
    RFLink is on a arduino uno working well as i tested it in the serial monitor so that the somfy stores reacted well on the instructions:

  • 10;RTS;6a643d;0;UP; => Kleine store
    10;RTS;6a643d;0;DOWN; => Kleine store
    10;RTS;6a643d;0;STOP; => Kleine store
    For me it is a problem in openhab: how to solve it?
    Less people who uses rflink has a problem in OH4, so I wait till the problems come and someone update the binding jar

If you have any suggestions I would appreciate them to know!

Sorry, still some elements:

  • Also in bundle:list => 343 │ Active │ 80 │ 4.0.4 │ openHAB Core :: Bundles :: Serial Transport for Java Communications API
    after installing serial transport with “feature:install openhab-core-io-transport-serial-javacomm” and not “feature:install openhab-openhab-core-io-transport-serial-javacomm” as mentioned in “https://github.com/cyrilcc/org.openhab.binding.rflink
  • I have put the jar file in “/etc/openhab” but also in “-rwxrwxrwx 1 openhab openhab 79467 Nov 17 17:11 /etc/openhab/org.openhab.binding.rflink-3.1.0-SNAPSHOT.jar”
  • but also in “-rw-r–r-- 1 openhab openhab 79467 Nov 17 10:49 /usr/share/openhab/addons/org.openhab.binding.rflink-3.1.0-SNAPSHOT.jar”
    I did not change the rights because it is installed already
    I also asked myself: “How do you access the bindings installed in the addons folder ?”
    Therefore I asked Phil what he understand under “dependencies”

I think “dependency” is for the library commons-io-2.8.0.jar (Apache Commons, which were removed from new OH distributions).

I am at the same point as you are: my RFLink binding seems to mount ok (I see it with bundle:list for instance). But from the GUI I can’t find where this binding is. Even if I try do create an Item, the GUI doesn’t show the RFLink binding :frowning:

For now, I’m staying with the “old” OH v3.1.0. But JavaScript support in rules is not the same as in OH4 (I can’t “require” an external lib for instance). But my sensors are working… :wink:


Did you try adding things thru the things file?
In case that works the issue may be related to a change in how bindings work in oh 4

Indeed, adding things through the things file does not work.
So I wonder what is the difference with OH3 that the binding in O does not works?

As written before:

  • the binding is installed in Bundle:list
  • but the bridge cannot be seen or used in a new thing

You will not find the 3.x Binding to add Things through the UI as the structure had changed for openHAB 4.
It now uses Addon.XML instead of Binding.XML internally….
You can try to add Things via textual config though….


Sorry should have made it clear that my comment was intended for @manumunier.

@Herwig_Vroman my best guess is that it might be some dependency that is causing the issue for you.
I am running OH 4 and the org.openhab.binding.rflink-3.3.0-SNAPSHOT ( installed via the addon folder is working for me.

Many thanks!
But where can I find this jar file? (org.openhab.binding.rflink-3.3.0-SNAPSHOT (


But I guess you have used textual config, not UI config….


@Herwig_Vroman I guess I must have build it my selv :slight_smile:

I tried to create a version for OH 4.0.0 that you can download from here:

I tried to fix adding things from the GUI, but something is still wrong.

You’d better commit your changes to a new branch in your github fork, so we can check whats wrong.

A look in the log quickly showed that the issue was, I had not removed the author tag in the Addon.xml.
Anyway I create a new version where things can be added from the GUI. I did not test it but I hope its working. If somebody can confirm this it would be nice.