RFXCom module remains reported offline

Hi everybody,
Last weeks I brought all my Tasmota devices online and got some rules implemented to automate things around the house. For a few days I’m trying now to get my sensors (Kaku) alive via a RFXCom transceiver. Problem no matter what I try the RFXCom remains reported offline in Openhab. I/m coming from FHEM and in that configuration the RFXCom worked fine.

I’m running Openhab in a container latest-debian (2.5.4). The RFXCom is in the container on /dev/ttyUSB0 and if I do cat /dev/ttyUSB0 in the container I see the button presses from Kaku coming in. Openhab is a member of the dialout group and /dev/ttyUSB0 has rw permission for the dialout group.

I’ve defined my RFXCom in PAPER UI manually via the RFXCom binding as " RFXCOM USB Transceiver" on /dev/ttyUSB0 with frequency 433.92MHz. Paper UI reports the device as offline. I’ve tried a restart of the docker container but that didn’t help, and also doesn’t give any clues in openhab.log.

What I have NOT done is setting the EXTRA_JAVA_OPTS="-Dgnu.io.rxtx.SerialPorts=/dev/ttyUSB0" under environment in the docker compose file. I’ve tried that but then the openhab container does not start anymore.

Can any of you help me with a working RFXCom configuration or pointers how to find out what is going on. I’ve searched the community forum but did not find anything that helped me out. Any help appreciated.

Hello,

Wat output do you get in terminal with this?

 dmesg | grep tty

Hi Levi,
I’m a bit limited with the docker container. dmesg “dmesg: read kernel buffer failed: Operation not permitted”

In the first reaction I assumed that you wanted dmesg in the container.
In case you want it from the host see below:

[ 6.504911] usb 5-4: FTDI USB Serial Device converter now attached to ttyUSB0

In /dev I’ve on the host:

lrwxrwxrwx 1 root root 7 mei 10 18:13 /dev/ttyRFXtrx433 -> ttyUSB0
crw-rw-rw- 1 root dialout 188, 0 mei 10 18:13 /dev/ttyUSB0

In the openhab container:

crw-rw-rw- 1 root dialout 188, 0 May 10 18:19 /dev/ttyUSB0

In the docker-compose file the tty devices are linked via:

devices:
  - "/dev/ttyRFXtrx433:/dev/ttyUSB0"

Looks oke to me but i have no experience with docker.
Did you try a full reboot not only the container?

Yes I did a full reboot just about half an hour ago. Did not help either. If I do a cat command in the container on /dev/ttyUSB0 I can see button commands coming in, so it looks like I 've access to the device in the container. I suspect I’m overlooking something simple in the binding in OH.
I 've tried a simple thing definition like

Bridge rfxcom:bridge:usb0 [ serialPort="/dev/ttyUSB0" ] {}

but that gave the same result. As I’m still struggling as a beginner, how can I activate debug logging in the container?

ssh -p 8101 openhab@localhost

Password : habopen

log:set TRACE org.openhab.binding.Rfxcom

To put it back to normal

log:set INFO org.openhab.binding.Rfxcom

OK thanks. Need some more time to get this done. I quickly exposed thar port on my docker container but that was not sufficient as firewall prevented access. Other thing I’m going to try is to prepare the old pi that was running fhem with openhabian and then do the setup from there. Once that is all working I will migrate to docker environment this will at least get the docker variable out of the loop and reduces complexity in the setup.

OK I tested the whole setup on the RPi and it worked without issues. So I went back to the main server and also there it works somehow. Sensor data comes in from the Kaku devices and is shown on Openhab. Only the status of the RFXCom bridge is reported offline. As a last resort I flashed the RFXCom with the latest firmware as on my device it was 3 years old. That did the trick everything works now as expected.