RFXCOM wont connect

Hi Guys,

Admittedly I new to OpenHAB but i think i have tired eveything and simply cant get the RFXCOM binding to find my RFXtrx433. If anyone can give me a pointer i would be very appreciative, the steps so far:

  • It wasn’t automatically picked up by Paper UI, so i tried adding manually via Paper UI. Shows as offline
  • Tried adding openhab user to the dialout group - Still shows as offline and gets the error below
  • Tried setting the symlinks as per the example (including add it to the openhab2 file - still gets the error below
  • Tried setting the symlinks to ttyUSB-9999 and removing the line for the openhab2 file - still gets the error below

Not sure what my next step should be… I am using a snapshot build from 2 days ago on a Pi3

2016-08-29 15:14:50.401 [INFO ] [ernal.connector.RFXComJD2XXConnector] - Connecting to RFXCOM device ‘A1WXPMFX’.
2016-08-29 15:14:50.409 [ERROR] [g.rfxcom.handler.RFXComBridgeHandler] - Connection to RFXCOM transceiver failed
java.io.IOException: device not found (2)
at jd2xx.JD2XX.openEx(Native Method)[190:org.openhab.binding.rfxcom:]
at jd2xx.JD2XX.openBySerialNumber(JD2XX.java:806)[190:org.openhab.binding.rfxcom:]
at org.openhab.binding.rfxcom.internal.connector.RFXComJD2XXConnector.connect(RFXComJD2XXConnector.java:56)[190:org.openhab.binding.rfxcom:]
at org.openhab.binding.rfxcom.handler.RFXComBridgeHandler.connect(RFXComBridgeHandler.java:161)[190:org.openhab.binding.rfxcom:]
at org.openhab.binding.rfxcom.handler.RFXComBridgeHandler.access$8(RFXComBridgeHandler.java:141)[190:org.openhab.binding.rfxcom:]
at org.openhab.binding.rfxcom.handler.RFXComBridgeHandler$1.run(RFXComBridgeHandler.java:114)[190:org.openhab.binding.rfxcom:]
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)[:1.8.0_65]
at java.util.concurrent.FutureTask.runAndReset(FutureTask.java:308)[:1.8.0_65]
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$301(ScheduledThreadPoolExecutor.java:180)[:1.8.0_65]
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:294)[:1.8.0_65]
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)[:1.8.0_65]
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)[:1.8.0_65]
at java.lang.Thread.run(Thread.java:745)[:1.8.0_65]

Hi James,

see https://github.com/openhab/openhab2-addons/issues/1163

ahhhh, it was then adding it as

“RFXCOM USB Transceiver”

that was the last bit of the puzzle. Thanks

@pauli_anttila Do you know how to remove that “native drivers for FTDI based devices” on Linux (raspbian) so it can just work?

@James_Hiscott See http://www.ftdichip.com/Support/Documents/AppNotes/AN_220_FTDI_Drivers_Installation_Guide_for_Linux.pdf

Im getting a similar issue , but rather than my RFX binding not connecting, it always connects. however, i then lose one or both of z-wave or Powermax. I think it might also be something to do with the FTDI driver, but not really sure. i know i can restore service to zwave and powermax simply by unistalling the RFXCOM binding - not ideal. im runing Windows 10 Pro, OH2 build 697.

i’ve seen an error talking about jd2xx drivers, but mainly for Apple/Linux devices. could my problem be similar?