RFXtrx433XL / RFXCom Thing keeps offline

Hello everyone,
hope that maybe someone is able to help me.
I am quite an openHAB Beginner. I am trying to connect the RFXtrx433XL Transceiver with openHAB (Rasp 4) in order to be able to control some somfy rts inwall shutters.

I started the project with testing the inwall shutters with the RFXmngr Software on my Windows PC. There i was able to pair the shutters with the Transceiver and also moving blinds up and down worked fine…

In the next step I want to integrate the Transceiver within present openhab Version.
I was able to install the RFXCOM Binding. In the next step I added manually the “RFXCOM USB Transceiver” as Item. The Problem is that the item reamains offline.

I already tried the following:

  • Symlinks
    (added the following line in etc/udev/rules.d/99-usb-serial.rules)
    SUBSYSTEM==“tty”, ATTRS{idVendor}==“0403”, ATTRS{idProduct}==“6015”, SYMLINK+=“ttyUSBRFXCOM”, GROUP=“dialout”, MODE=“0666”

(and added the following line in /etc/default/openhab2)
EXTRA_JAVA_OPTS="-Dgnu.io.rxtx.SerialPorts=/dev/ttyUSBRFXCOM/"

-Add the openhab user to the dialout group:
`$ sudo usermod -a -G dialout openhabian

  • I already made a total new openhab setup from scratch. Unfortunately within any improvements.

Log File shows (nearly every minute a new entry) as follows:

020-01-19 20:11:31.337 [ERROR] [internal.handler.RFXComBridgeHandler] - Error occurred during packet receiving, data: 140100010254290000000003001C10580000000000

org.openhab.binding.rfxcom.internal.exceptions.RFXComUnsupportedValueException: Unsupported value ‘84’ for TransceiverType

at org.openhab.binding.rfxcom.internal.messages.ByteEnumUtil.fromByte(ByteEnumUtil.java:37) ~[bundleFile:?]

at org.openhab.binding.rfxcom.internal.messages.RFXComInterfaceMessage.encodeMessage(RFXComInterfaceMessage.java:226) ~[bundleFile:?]

at org.openhab.binding.rfxcom.internal.messages.RFXComInterfaceMessage.(RFXComInterfaceMessage.java:165) ~[bundleFile:?]

at sun.reflect.GeneratedConstructorAccessor200.newInstance(Unknown Source) ~[?:?]

at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45) ~[?:1.8.0_222]

at java.lang.reflect.Constructor.newInstance(Constructor.java:423) ~[?:1.8.0_222]

at org.openhab.binding.rfxcom.internal.messages.RFXComMessageFactory.createMessage(RFXComMessageFactory.java:140) ~[bundleFile:?]

at org.openhab.binding.rfxcom.internal.handler.RFXComBridgeHandler$MessageListener.packetReceived(RFXComBridgeHandler.java:236) [bundleFile:?]

at org.openhab.binding.rfxcom.internal.connector.RFXComBaseConnector.sendMsgToListeners(RFXComBaseConnector.java:49) [bundleFile:?]

at org.openhab.binding.rfxcom.internal.connector.RFXComStreamReader.run(RFXComStreamReader.java:69) [bundleFile:?]

I would really appreciate if someone is able to give me some hints or may even solved the problem in the past.

Hi,
I have exactly the same issue. It works on windows but not on Openhabian.
Have you make any progress?

FredzoneNet

Same problem here. After update centos. Already cleared the cache and reinstall.

Hi Guys,
you have to set the RFXtrx433 to 433.92 MHz so the Binding will recognize it and show it “Online”.
As you can read here:


The Transmitter will use 433.42 MHz to communicate with the Somfy RTS devices.
I have tested this with the RFXmgr and they still worked.
Kind regards