Ring Contact Sensor

Hi all,

I’ve bought both a Gen1 and a Gen2 Ring Contact Sensor for testing, but I’m having trouble adding them to my OH instance.

I’m currently running 2.5 (I do have a 3.0 but that’s purely for testing at the moment) and have a USB Z-Wave stick configured as the bridge. I also have a Yale smart lock which is working flawlessly through this.

When I initiate a search for new Z-Wave things to put the controller into inclusion mode, and then power on the sensor, they are picked up automatically but display as “Node 004” and “Node 005” respectively. The Gen1 sensor also includes a string of numbers, but both devices remain as “unknown”.

I have read that some battery devices need to be woken several times, but I have kept the devices powered on for over 2 hours this afternoon with no further change.

Can anyone offer any advice on getting these devices recognised in OH?

Powered on isn’t enough. You need to interact with the device to force it to communicate with the controller. Often there is a button to press or something like that and often it’s the same thing you would do when including the device to the controller. Many battery powered devices will only way up every couple of days to report battery status when left on their own.

I’ve had battery devices that needed to be kept awake for five minutes for OpenHab to finish its configuration. The instructions for waking up a RIng contact sensor are:

  • Contact Sensors
    Contact Sensor (1st gen): Open and close the door or window. If that doesn’t work, tamper the device by opening and closing the cover.
    Contact Sensor (2nd gen): Tap the button on the front of the sensor.

Thanks both for your replies, but I’m still not having any luck.

Have been keeping the sensors awake by pressing button (gen2) and by moving magnet away to activate (gen1) but the inbox isn’t updating. In fact, I’ve now got 4 nodes listed instead of 2!

image

If I remove all of these, a scan for new devices brings them all back instantly.

Really leaning towards having to go ESP with wired reed switch now, would’ve preferred a wireless solution though!

Since you’re running 2.5, are you sure those contact sensors in the database of your version of the binding? The first gen one I think would be, since it looks like it was added to the database in 2.4 but it looks like the gen 2 one was only added in 3.1 back of February 2021 and I don’t think the database back ports to older versions but I could be wrong on that.

Ah, you could have a point here, certainly with the Gen2 at least.

As said in my OP, I do have a 3.0 instance so I could detach the Z-Wave stick from the 2.5 VM and move it to the 3.0 VM for testing this.

Thanks, will give it a go this weekend and report back.