Rollback OH3 Migration on Synology NAS Docker from 3.2 to 3.3

Hi all,

i tried to update my OH3 3.2.0 setup on my Synology NAS DSM 7.1 in a Docker environment to 3.3.0.

  • I installed openhab/openhab:latest (3.3.0) as new container.
  • Shut down my openhab/openhab:3.2.0 (whyever i installed this as a fixed version?)
  • Started the new (latest - 3.3.0) container
    When this does not work and (i saw some exceptions in openhab.log) i shutdown 3.3.0 and started 3.2.0 again but 3.2.0 throws the same exceptions now.

Maybe this was a little bit naive. But any advice why i got this exceptions?
I checked and /volume1/@appstore/openHAB/addons exists on my NAS, but in my opinion it has to use the directories i setup in the docker container (volume settings → /docker/openhab/…)?

2022-09-01 19:24:23.635 [WARN ] [org.apache.felix.fileinstall        ] - /volume1/@appstore/openHAB/addons does not exist, please create it.
2022-09-01 19:24:23.671 [ERROR] [org.apache.felix.fileinstall        ] - Cannot create folder /volume1/public/openHAB/userdata/tmp/bundles. Is the folder write-protected?
2022-09-01 19:24:23.677 [ERROR] [org.apache.felix.configadmin        ] - [, id=44, bundle=17/mvn:org.apache.felix/org.apache.felix.fileinstall/3.7.2]: Unexpected problem updating configuration org.apache.felix.fileinstall.2dc3ab11-9370-4dae-89ee-cc152254d860
java.lang.RuntimeException: Cannot create folder: /volume1/public/openHAB/userdata/tmp/bundles

Thanks in advance…

Sounds like it has something todo with directory permissions?
Maybe the second install created a new user which also effects the original install??

Just a thought…

Sound promising @mwildbolz
Now i have to found out how the users works in openHAB?
The directory “openHAB” was created from the docker install process with this user id:

drwxr-xr-x 1       1036 users     232 Sep  1 18:41 openHAB

But i cannot find the user with

cat /etc/passwd | grep 1036

Thats what i googled so far. But i do not know how to fix this?

I found a “somehow” solution and now the new setup works (so far).
I cannot install my influx binding. But the rest works now with 3.3.0 setup.

I cannot reproduce the steps here. But in short:

  • Backup of my docker/openhab files
  • Deleting all that i found on my NAS regarding openHAB. Including all docker container
  • Installing openHAB 3.3.0 from the scratch
  • Trying to SYNC docker/openhab with my backup file (this is some work to do)

But after starting openHAB there are no significant errors. The main things and items are running fine.