Rolleshutter broken since latest snapshot

Hi all,

Since few days, the Rollershutter widget in the Hadroid app look broken in the Openhab2 snapshots.
They appear as basic Switch and send ON/OFF command on the event bus.
I get same error even with dummy rollershutter item defined without any binding.

In the log file, i get :
“Received HTTP POST request at ‘items/Shutter4’ with an invalid status value ‘ON’.”

My setup is Raspberry pi with almost all items defined in conf files.

I’ve not been able to sort this problem yet.

Made some test with clean install of Openhab2 with only one Rollershutter item and it seems to be reproducible. So not linked to my config apparently.

Everything working ok for me on Build #447.

Same problem here …

Peter

I just tested it on Build #461, but all looks fine. Can you confirm that the issue still exists?

@Kai
The problem is still there for me with the latest build.

Have a look at the screenshot (left side HABDroid, right side basic UI)

Just updated to latest snapshot, exact same problem.
Basicui is working fine but Habdroid stills display rollershutter as switch and sends ON/OFF command on the event bus.

Did some research:

My Shutters are defined as Rollershutter in my shutters.items

Rollershutter   Shutter_GF_Living_Side_Small    "Seite klein [%d %%]"   <rollershutter> (GF_Living,Shutters)  

They are referenced as Switch in my sitemap

Switch item=Shutter_GF_Living_Terrace_Window

After reading the docs i’m unsure if this is valid (but it has worked ever since …)
If I define the shutters as slider or setpoint in the sitemap, they are rendered identical ok in HABDroid and in the WEBIf.

But defining the shutter-control as setpoint has the drawback, that the middle “Stop”-Button is missing then.

Me too :wink:
But I agree that what the Basic UI does in this case is definitely better than what HABDroid does. I really wonder if this was ever working differently in HABDroid, I very much doubt it. But feel free to enter an issue at https://github.com/openhab/openhab.android/issues about improving HABDroid to render it in the same way as Basic UI does.

Filed a bug-report as https://github.com/openhab/openhab.android/issues/219

I’m running into the exact same issue.
Rollershutters in combination with Habdroid on OH1 rendered fine… in my OH2 setup (build 460) they are rendered as switched and send out invalid commands (ON/OFF) to OH2.

Hope this gets fixed soon… :slight_smile: