Rotel Binding Function

Continuing the discussion from Control of Rotel equipments:


Hi There,

I am very new to openhab, so it’s possible my question comes from a lack of understanding,. If so, apologies.

I have some Rotel gear, including an RC-1590. I’ve installed the binding, punched in the IP, and set it up as a “thing” using the paperUI.

I can see the device as showing on line, but beyond that, it doesn’t appear to respond to any button commands or updating status.

I know that the unit is online and talking to the network, as I’ve used a volume add in for Roon that talks over IP.

The Rotel unit is on FW v. 1.41. I mention this because it broke the Roon volume control add in, which had to be updated for the new FW – in case that has some bearing here (don’t know any particulars beyond that, sorry).

Thanks in advance for any help.

Note that I found a new version of the protocol version for the model RC-1590.

As of software V1.40, the RS232 and IP protocol was updated with changes to some commands as well as all feedback strings. This change will impactexisting control systems so any connected control systems should be updated to utilize the new protocol before updating the software in the RC-1590.

So a change is necessary in the binding to support your model with your firmware.

Of course I will propose a fix in the coming days.
The change may be even easy but I need first to analyze the new documentation. I guess this is the same change of protocol that occurred with few other models and which is already supported by the binding.

The fix is in the review process. If we have chance, it could be included in next version 2.5.6.

Fix is now merged and will be included in 2.5.6.

No feedback??

Hi Lolodomo,

Apologies for no reply – I tinkered then got distracted.

However – I am back, and have seen your reply. Firstly, thank you for your effort and help. This binding works quite well with the RC-1590 model. I very much appreciate that this is available – I am using it in my house to hide gear away and control from an ipad.

I am having only one issue – I can’t seem to select the PC USB source. I can select CD, optical1, etc, but not PC USB (which is of course, the one I use most of the time).

In my sitemap file, I am using upper case source names in the mappings e.g. “OPTICAL1”=Optical1, “OPTICAL2”=Optical2, etc. I haven’t been able to crack the right combo for PCUSB. In another app (a Roon extension) I have successfully used pc_usb (lower case). The namings in the Rotel manual ( have not been helpful.

I am using firmware v 1.1, so am using ASCII.

Many thanks for any help you can offer – again, this is a very useful binding – just one small bug that I can see.

p.s. one more, if this helps – when I physically press the button on the unit to select the PCUSB source, I see:
2021-02-14 10:11:44.475 [INFO ] [openhab.event.ItemStateChangedEvent ] - Item ‘MasterBedroomRC1590StereoPreamplifier_SourceInput’ changed from OPTICAL1 to PCUSB

But if use PCUSB as the selection source in the sitemap file, it doesn’t work.

Thanks again.

I hope you know that you can let the binding build the list of options for your channel.
Hardcoding a mapping has only an interest if you want to restrict to a subset of input sources.
Looking at the code, I can confirm that the value to be used in OH is PCUSB. The binding will then use value pc_usb in the message sent to the device.
If it does not work, that would mean the Rotel doc is wrong. I will check it again.

Checking Rotel doc you linked, the expected command should be pcusb. So there is a bug in the binding!
I will have to check if this command value is specific to this model or not.
I will prepare a fix in the next days.
I hope this is not something that changed with a new firmware,

After re-re-reading the spec, with a firmware priori to 1.4, the command that must send the binding is “pc_usb!”. For firmware 1.4 and newer, it shoud be “pcusb!”.
So if your firmware is 1.1, the binding should work if you send “PCUSB” to the channel.
Did you select ASCII v1 or ASCII v2 ?

By the way, my feeling is that the value is wrong for ASCII v2 mode in the binding. To be investigated.

Hi, sorry, I am using version 1.41 of the firmware – typo by me. I’m using the ASCII protocol.

Attached is a screengrab of the naming I’m using for the roon volume control, where pc_usb works successfully (also v 1.41 firmware on this device).

As to using a server provided list – I have tried using that via habpanel (I do not know how to make that work for a handwritten sitemap yet ;)), and it still does not work.

I also have another model of Rotel device – an RA-1592; it should be very similar to the RC-1590. I’ll try to conenct to that this evening and see how it behaves.

Thank you again.

Ok so you should have setup ASCII v2 and the binding has to be fixed to send the right command for PC USB source.
I must be sure that the fix has to be applied to all models using ASCII v2 protocol and having a PC USB source. If not, it will make the fix more difficult.

Hi, yes, am running ASCII. Just tested my RA-1592 – it has same behaviour as the RC-1590.


ASCII v2, to clarify.

Good news, the command is the same for all models using the most recent ASCII mode.
I will propose a fix later today.

That’s great! Look forward to testing it out. Thanks in advance.

Fix proposed:

1 Like

Thanks very much Lolodomo. Very much appreciate you doing this so quickly.

Just to ask a very noob question – what is the process from here? Do I wait for an update to openhab versions to sweep up this fix?


The review & merge should be fast (the change is very small), Then the next day you will get the fix in the nightly build.

Perfect, thanks.

Fix has now been merged. You should find it in next snapshot tomorrow morning (if the build succeeds).
Take me informed, not in one year if possible.