RPi 4 high load with openHAB extension 1.0.0

I have some problems with the new openhab addon. When I configure the addon as i think it should:
Openhab 3.0 on my Rpi4 goes nuts. CPU Shoots to 100% and load becomes higher than 2.0 until it crashes, so i have to reload openhab. It only happens when i use:

    "openhab.languageserver.remoteEnabled": true,
    "openhab.languageserver.remotePort": 5007,

I always was a problem but with the new update, i have to reboot openhab. Normally not a problem but with openhab 3.0 the Google Voice TTS sometimes works, sometimes not. So every reboot is a gamble if it works fine. Can check it after 10 minutes or so, if it don’t reboot again. etc. etc. pretty frustrating.

Is it common Rpi users cannot use the openhab.languageserver.remoteEnabled ?

My config:

"workbench.iconTheme": "openhab",
    "openhab.languageserver.remoteEnabled": true,
    "openhab.languageserver.remotePort": 5007,
    "openhab.connection.host": "192.168.*.*",
    "openhab.connection.port": 8080,
    "openhab.connection.authToken": "oh.*******************************************",
    "openhab.consoleCommand": ""

Hey, i have cut your post out to a new topic in the correct section.
No need to mix up other (only partly related) topics.

I am no LSP expert, but it is known as pretty “chatty”, so this is probably depending on your environment.

Can you give us a screenshot/overview of how your config folder looks like?
How many different files, how many rules files, how many files opened parallel?

I cannot screenshot it because it doesnt fit in my screen. It’s a lot, but at the time of enabling LSP, there where no files opened in VSC.

I have 31 item files, 36 rules files and 16 thing files.

Also with the new update, when i hover with the mouse over items, i don’t see the status anymore. Before this was no problem, also with LSP off. So that’s the reason i tried it on and openhab went crazy. This was couple of weeks ago. Today (due to a defect laptop) i use another laptop with and old version and everything was fine. But when I updated VSC i tried LSP again and openhab went crazy. So I’m a bit in the dark whats going on :slight_smile:

That’s a lot, but should not have affected the extension too much with no files opened.

This is not provided via LSP service, so LSP should not have to be turned on for it.

Are you able to get updates to the item and thing browser with your current settings?
Hovering function and item/thing view are both provided via rest api which can be turned off/on with its own setting.

Can you check of the openHAB extension output gives any messages?

Thought so that LSP was more on debugging the code via language server protocol but wasn’t completely sure. I don’t need that, code alway with logfile open.

Are you able to get updates to the item and thing browser with your current settings? > not sure how to check this or what you mean exactly.

openhab extentsion doesn’t give any complaints:

openHAB vscode extension has been activated

I load my openhab folder and work with this, should be rest api but i think it isn’t:

Could you please check if restApi is activated in your settings?
There is no openHAB logo in the sidebar so there is no item and thing browser available currently.

This is usually the case when rest api is deactivated.

Solved the hover problem! I thought the API token was enought and never configured my username and password since i use openhab 3 with API token.

You where correct, the restAPI didn’t work, that was the problem. Thanks! I leave LSP disabled as it doesn’t do anything for me :slight_smile:

Just out of interest what does “my username and password” mean?

Are the credentials for main ui or your pi meant with this or do you have a basic auth configuration configured on top?

I meant the username from openhab main ui. I don’t run any other auth configuration on top of openhab.

Then you shoudl definetely remove those settings.
BasicAuth is a completely independent and different technique.

It has to work with an auth token standalone.

That’s strange then. Can’t test it right away but will tomorrow afternoon. When I filled those credentials everything works fine and I see the openhab logo. Think I’m doing something wrong but not sure where…