RPi3 Installation issue - WiFi

Der Community,

I’m facing strange issues with my openhabian Installation.
First of all i tried The WiFi based installation where you edit the settings in the openhabian.conf file according to your WiFi.
Didn’t work.
After that I tried installation with Ethernet. This worked out in the third trial.
Now I’d like to get my openhabian to use WiFi. Without success. I tried the WiFi settings option in the openhabian-config, it tells !e that setting was successful and that I should reboot but after reboot the RPi3 is not connecting to my WiFi. Hardware itself must be fine because it was running libreelec on WiFi only with no issues until last week…

Anybody can give me a hint how to get the WiFi working?

Thanks in advance…

Well. Ok.
Since I was not just sitting there waiting for help I did do the following:

I reflashed the sd with raspbian in order to go the way of manual installation.
So I booted raspbian and tried to connect WiFi there. Didn’t work. It listed my SSID but when I entered my password it was just like ignoring this. It just didn’t do anything.
And I tried a couple of times…
Since my router is giving the opportunity of having a separate guest network I just tried this one and it did work like a charm. Immediately connected.

So now I really wonder what’s going on here. The passwords are similar in format and content, the SSID of the guest network has the same name as the master network just followed by “_guest”…

Just raspbian and openhabian totally ignoring one of them while libreelec is using it without any issues…

Any ideas?
Tha for your input.

The guest network subnet is probably different. Disable the guest network and try again, please! Rgds.

Ok… On it goes:

I did try:

  • switched off guest network and retry. No success.
  • switched off guest network, renaming the main WiFi, same password. No success.
  • deleted entire guest network from the router settings, gave main WiFi SSID name and password of guest WiFi. No success.
  • try to connect to my cell phone hotspot. WiFi connection built up immediately.

So what the hell is wrong with my WiFi?
And no, I did not limit the adding of new devices…

May be your wifi security type is WEP, if it’s WEP change that to WPA in the router settings…