RRD4J persistence config files not available (at least for me...)

Dear Community,

after the installation of openHAB 2 on my Freenas system (11.3-U5) I want to create temperature charts, based on the MAX! thermostats.The integration of the Cube LAN Gateway and all devices worked well and is showing the wished output on HABPanel.
After the installation of rrd4j presistence I read that I would need at least a persistence strategy and a datasource (https://www.openhab.org/addons/persistence/rrd4j/).

And now the trouble begins… The access to OH is currently made through the shell, and I can access the folder “etc”, but there is no folder “services” (as I expected after reading the documentation), only a file with that name. Am I totally wrong where to find the rrd4j config and persist file or is that special because of my jail installation?

Thanks in advance,

How did you install openHAB? If using a packet manager like apt or yum, this would create a filolder /etc/openHAB2/ and within the conf-stuff of openHAB.
If installing manually, it‘s presumably another file location.

Hi Udo,
i used the pkg installer, but there is no openHAB2 folder or similar. I tried all folders, which are in the /etc directory, but didn´t have any success (see files attached).
The rc.d looked the most like a conf-folder, but didn´t include the files I searched for


I’m pretty sure that openHAB is installed in another folder, including all configurations.

Please do a

find / | grep openhab

to get the installation folder.

1 Like

Thanks Udo for your help, with this function I found the openHAB2 and the RRD4J folder:
If anyone has the some problem, here it is:

1 Like

But this is not the conf folder. keep on searching :wink: e.g.

find / | grep persistence/readme.txt

This will hopefully result in the path to the correct folder. :wink: I’m not sure if the slash has to be escaped…

If you installed the package using the package manager you also should be able to find the installed files using the package manager:

pkg info --list-file PACKAGE-NAME-HERE

Thanks a lot to both of you!
Found the correct path under /usr/local/etc/openhab2/persistence and got my charts working within 5 minutes :slight_smile: