Rule with the Fibaro Smoke Sensor

Tags: #<Tag:0x00007f5c95672c50>

@mstormi, thanks for the screenshot, but could you please also post Association Groups screen and items configuration strings related to the FGSD-002 device.

Controller is in all 5 association groups

Switch EG_Wohnen_Rauchmelder_Rauch "Brandmelderalarm SMOKE"     <fire>          (Rauchmelder)                   { zwave="54:command=sensor_alarm,alarm_type=1" }
Switch EG_Wohnen_Rauchmelder_Hitze "Brandmelderalarm HEAT"     <fire>          (Rauchmelder)                   { zwave="54:command=sensor_alarm,alarm_type=4" }
Number EG_Wohnen_Bat "Wohnen Brandmelder [%s %%]"               <battery>       (EG_Wohnen,Batterien)           { zwave="54:command=battery" }

I also added

Switch EG_Wohnen_Rauchmelder_Basic_Rauch "Brandmelderalarm BASIC SMOKE" <fire>  (Rauchmelder)                   { zwave="54:command=sensor_binary,sensor_type=2,respond_to_basic=true" }
Switch EG_Wohnen_Rauchmelder_Basic_Hitze "Brandmelderalarm BASIC HEAT" <fire>   (Rauchmelder)                   { zwave="54:command=sensor_binary,sensor_type=5,respond_to_basic=true" }

but I haven’t seen FGSD002 use it yet.

With my Everspring smoke detector I had to use Contact instead of Switch … could be worth a try …

Contact SF812_1_C “Sensoralarm Smoke [%s]” (gTest) { zwave=“2:command=sensor_alarm” }

@mstormi, so as you can see my config is the same as yours. I’ve also added my sensor to all 5 association groups. But I NEVER get:

  1. 255 for Smoke SENSOR_ALARM, I always get 0. So, how can I distinguish between “calm” and “alarm” states, as in both of them the sensor reports “0”? It doesn’t matter for me whether 0 (CLOSED) means “calm” and 255 (OPEN) means “alarm”, or vice versa, 0 means “alarm” and 255 means “calm”. But these two states SHOULD BE DIFFERENT, that’s the main problem.
  2. Heat SENSOR_ALARM at all, even when the temperature rises above the configured threshold.

Here are my logs:
First is when the sensor is in “calm” state, I press the button, wait for one beep and green light, and press the button again (the manual states that in this case the sensor will “send device state to associated devices”). As you can see, the sensor answers with one General ALARM report, two(!) sequential Smoke SENSOR_ALARM reports, and one BASIC report:

23:29:13.127 [DEBUG] [ApplicationCommandMessageClass:38 ] - NODE 46: Application Command Request (ALIVE:DONE)
23:29:13.127 [DEBUG] [ApplicationCommandMessageClass:56 ] - NODE 46: Incoming command class ALARM
23:29:13.127 [DEBUG] [z.i.p.c.ZWaveAlarmCommandClass:82 ] - NODE 46: Received Alarm Request
23:29:13.127 [DEBUG] [z.i.p.c.ZWaveAlarmCommandClass:94 ] - NODE 46: Alarm report - Value = 0
23:29:13.127 [DEBUG] [z.i.p.c.ZWaveAlarmCommandClass:112 ] - NODE 46: Alarm Type = General (0)
23:29:13.128 [DEBUG] [.z.internal.ZWaveActiveBinding:450 ] - NODE 46: Got a value event from Z-Wave network, endpoint = 0, command class = ALARM, value = 0
23:29:13.194 [DEBUG] [ApplicationCommandMessageClass:38 ] - NODE 46: Application Command Request (ALIVE:DONE)
23:29:13.194 [DEBUG] [ApplicationCommandMessageClass:56 ] - NODE 46: Incoming command class SENSOR_ALARM
23:29:13.194 [DEBUG] [c.ZWaveAlarmSensorCommandClass:85 ] - NODE 46: Received Sensor Alarm Request
23:29:13.195 [DEBUG] [c.ZWaveAlarmSensorCommandClass:104 ] - NODE 46: Alarm Report: Source=46, Type=Smoke(1), Value=0
23:29:13.195 [DEBUG] [.z.internal.ZWaveActiveBinding:450 ] - NODE 46: Got a value event from Z-Wave network, endpoint = 0, command class = SENSOR_ALARM, value = 0
23:29:13.207 [DEBUG] [ApplicationCommandMessageClass:38 ] - NODE 46: Application Command Request (ALIVE:DONE)
23:29:13.207 [DEBUG] [ApplicationCommandMessageClass:56 ] - NODE 46: Incoming command class SENSOR_ALARM
23:29:13.207 [DEBUG] [c.ZWaveAlarmSensorCommandClass:85 ] - NODE 46: Received Sensor Alarm Request
23:29:13.207 [DEBUG] [c.ZWaveAlarmSensorCommandClass:104 ] - NODE 46: Alarm Report: Source=46, Type=Smoke(1), Value=0
23:29:13.208 [DEBUG] [.z.internal.ZWaveActiveBinding:450 ] - NODE 46: Got a value event from Z-Wave network, endpoint = 0, command class = SENSOR_ALARM, value = 0
23:29:13.311 [DEBUG] [ApplicationCommandMessageClass:38 ] - NODE 46: Application Command Request (ALIVE:DONE)
23:29:13.312 [DEBUG] [ApplicationCommandMessageClass:56 ] - NODE 46: Incoming command class BASIC
23:29:13.312 [DEBUG] [z.i.p.c.ZWaveBasicCommandClass:74 ] - NODE 46: Received Basic Request
23:29:13.312 [DEBUG] [z.i.p.c.ZWaveBasicCommandClass:78 ] - NODE 46: Basic Set sent to the controller will be processed as Basic Report
23:29:13.312 [DEBUG] [z.i.p.c.ZWaveBasicCommandClass:107 ] - NODE 46: Basic report, value = 0x00
23:29:13.313 [DEBUG] [.z.internal.ZWaveActiveBinding:450 ] - NODE 46: Got a value event from Z-Wave network, endpoint = 0, command class = BASIC, value = 0
23:29:13.323 [DEBUG] [ApplicationCommandMessageClass:38 ] - NODE 46: Application Command Request (ALIVE:DONE)
23:29:13.324 [DEBUG] [ApplicationCommandMessageClass:56 ] - NODE 46: Incoming command class BASIC
23:29:13.324 [DEBUG] [z.i.p.c.ZWaveBasicCommandClass:74 ] - NODE 46: Received Basic Request
23:29:13.324 [DEBUG] [z.i.p.c.ZWaveBasicCommandClass:78 ] - NODE 46: Basic Set sent to the controller will be processed as Basic Report
23:29:13.324 [DEBUG] [z.i.p.c.ZWaveBasicCommandClass:107 ] - NODE 46: Basic report, value = 0x00
23:29:13.325 [DEBUG] [.z.internal.ZWaveActiveBinding:450 ] - NODE 46: Got a value event from Z-Wave network, endpoint = 0, command class = BASIC, value = 0

So, from the log above one would come to a conclusion that the values in “calm” state are 0 (CLOSED).

Next, here what happens when the temperature rises above the threshold (15 C):

00:23:13.738 [DEBUG] [ApplicationCommandMessageClass:38 ] - NODE 46: Application Command Request (ALIVE:DONE)
00:23:13.738 [DEBUG] [ApplicationCommandMessageClass:56 ] - NODE 46: Incoming command class ALARM
00:23:13.738 [DEBUG] [z.i.p.c.ZWaveAlarmCommandClass:82 ] - NODE 46: Received Alarm Request
00:23:13.738 [DEBUG] [z.i.p.c.ZWaveAlarmCommandClass:94 ] - NODE 46: Alarm report - Value = 0
00:23:13.739 [DEBUG] [z.i.p.c.ZWaveAlarmCommandClass:112 ] - NODE 46: Alarm Type = General (0)
00:23:13.739 [DEBUG] [.z.internal.ZWaveActiveBinding:450 ] - NODE 46: Got a value event from Z-Wave network, endpoint = 0, command class = ALARM, value = 0

And that’s all, it is the only thing that I get from the sensor when the temperature threshold is hit. Again, the value is 0 (CLOSED), so the value didn’t change against the “calm” state, and it is General ALARM, not Heat SENSOR_ALARM. When I request sensor’s state at this moment (again, by pressing the button, waiting for one beep and green light, and pressing the button again, I get exaclty the same as in the first log above, absolutely no difference.

Finally, I hide the sensor under several pillows (so that that my wife and neighbours won’t be shocked by the very loud beeper :laughing:), and press and hold the button for 5 seconds to trigger smoke alarm test mode. And here is what I get in the logs when the beep starts:

10:10:42.599 [DEBUG] [ApplicationCommandMessageClass:38 ] - NODE 46: Application Command Request (ALIVE:DONE)
10:10:42.599 [DEBUG] [ApplicationCommandMessageClass:56 ] - NODE 46: Incoming command class ALARM
10:10:42.599 [DEBUG] [z.i.p.c.ZWaveAlarmCommandClass:82 ] - NODE 46: Received Alarm Request
10:10:42.599 [DEBUG] [z.i.p.c.ZWaveAlarmCommandClass:94 ] - NODE 46: Alarm report - Value = 0
10:10:42.599 [DEBUG] [z.i.p.c.ZWaveAlarmCommandClass:112 ] - NODE 46: Alarm Type = General (0)
10:10:42.600 [DEBUG] [.z.internal.ZWaveActiveBinding:450 ] - NODE 46: Got a value event from Z-Wave network, endpoint = 0, command class = ALARM, value = 0
10:10:54.700 [DEBUG] [ApplicationCommandMessageClass:38 ] - NODE 46: Application Command Request (ALIVE:DONE)
10:10:54.700 [DEBUG] [ApplicationCommandMessageClass:56 ] - NODE 46: Incoming command class ALARM
10:10:54.701 [DEBUG] [z.i.p.c.ZWaveAlarmCommandClass:82 ] - NODE 46: Received Alarm Request
10:10:54.701 [DEBUG] [z.i.p.c.ZWaveAlarmCommandClass:94 ] - NODE 46: Alarm report - Value = 0
10:10:54.701 [DEBUG] [z.i.p.c.ZWaveAlarmCommandClass:112 ] - NODE 46: Alarm Type = General (0)
10:10:54.702 [DEBUG] [.z.internal.ZWaveActiveBinding:450 ] - NODE 46: Got a value event from Z-Wave network, endpoint = 0, command class = ALARM, value = 0
10:10:54.763 [DEBUG] [ApplicationCommandMessageClass:38 ] - NODE 46: Application Command Request (ALIVE:DONE)
10:10:54.764 [DEBUG] [ApplicationCommandMessageClass:56 ] - NODE 46: Incoming command class ALARM
10:10:54.764 [DEBUG] [z.i.p.c.ZWaveAlarmCommandClass:82 ] - NODE 46: Received Alarm Request
10:10:54.764 [DEBUG] [z.i.p.c.ZWaveAlarmCommandClass:94 ] - NODE 46: Alarm report - Value = 0
10:10:54.764 [DEBUG] [z.i.p.c.ZWaveAlarmCommandClass:112 ] - NODE 46: Alarm Type = General (0)
10:10:54.765 [DEBUG] [.z.internal.ZWaveActiveBinding:450 ] - NODE 46: Got a value event from Z-Wave network, endpoint = 0, command class = ALARM, value = 0

Again, the same as with overheating, the value is 0 (CLOSED), so the value didn’t change against the “calm” state, and it is General ALARM, not Smoke SENSOR_ALARM. You may see that it reports General ALARM with value = 0 when the alarm starts (10:10:42), and it reports General ALARM with value = 0 again when the alarm finishes 10 seconds later (10:10:54).

I hope that I have clearly explained what happens with my sensor. As I can see in this thread above, I have the same situation as @GaryWes has. GaryWes, have you resolved your issue?

Hi @roher,

Unfortunately, I still have the same problem :confused: I do’nt understand how to operate this sensor…

Hi! I have written an email with the problem description and logs to support@fibaro.com. Hope they will answer something useful. I’ll post here their reply.

Hello!
Here is the Fibaro’s answer:

Dear Sir,
First off all I would like to mention that “test” alarm does not send the alarm frame.
Fibaro smoke detector FGSD-002 according to the Z-wave plus send in the lifeline (1st group) CC Notification (V5) which is also related with Z-wave plus.
First of all make sure that your main controller support Z-wave plus and CC Notification (V5).
For backward compatibility, you can use other groups (5,4,3,2) but in order to fully support our Smoke detector your main controller have to know CC Notification (V5) in order to set it in the lifeline.
Information about association groups you can find for example here: http://www.pepper1.net/zwavedb/device/675
FGSD-002 is tested for various standards also due to the Z-Wave standard.
To avoid doubling frames, set the main controller only in the one group. For example in the lifeline.

So, what I’ve got from it:

  1. Non-Z-wave plus controllers (as mine) don’t support all functions of this sensor.
  2. The sensor won’t send any alarm frame when the alarm is triggered using “test mode”. So, to know what command classes with what values are being sent, we have to trigger a real smoke alarm.

Open questions are the following:

  1. Is non-Z-wave plus controller be able to get overheat alarm from the sensor? I’ve already asked Fibaro about it, waiting for the answer.
  2. How to trigger real smoke alarm? I’ve already tried with a match and a candle (in 5 cm from the sensor), but the sensor doesn’t react on them :frowning: How much smoke does the sensor need to trigger smoke alarm, does anybody know? Sensivity is set to Normal.

You could use a Testspray for smoke detectors e.g. http://www.pollin.de/shop/dt/MDI3OTE0OTk-/Haustechnik/Sicherheitstechnik/Ueberwachungssysteme/Rauchmelder_Testspray.html

I also have problems with configuring the FGSD002 Fibaro Smoke Sensor. When i trigger the sensor with actual smoke (@roher: You only need enough), I get the following response:

2015-11-30 21:49:30.335 [DEBUG] [b.z.i.protocol.ZWaveController:190 ]- Message: class = ApplicationCommandHandler (0x04), type = Request (0x00), payload = 00 0E 09 71 05 00 00 00 FF 01 02 00 
2015-11-30 21:49:30.335 [DEBUG] [ApplicationCommandMessageClass:38  ]- NODE 14: Application Command Request (ALIVE:PING)
2015-11-30 21:49:30.335 [DEBUG] [ApplicationCommandMessageClass:56  ]- NODE 14: Incoming command class ALARM
2015-11-30 21:49:30.336 [DEBUG] [z.i.p.c.ZWaveAlarmCommandClass:82  ]- NODE 14: Received Alarm Request
2015-11-30 21:49:30.336 [DEBUG] [z.i.p.c.ZWaveAlarmCommandClass:94  ]- NODE 14: Alarm report - Value = 0
2015-11-30 21:49:30.336 [DEBUG] [z.i.p.c.ZWaveAlarmCommandClass:112 ]- NODE 14: Alarm Type = General (0)
2015-11-30 21:49:30.336 [DEBUG] [b.z.i.protocol.ZWaveController:682 ]- Notifying event listeners: ZWaveAlarmValueEvent
2015-11-30 21:49:30.336 [DEBUG] [.z.internal.ZWaveActiveBinding:433 ]- ZwaveIncomingEvent
2015-11-30 21:49:30.336 [DEBUG] [.z.internal.ZWaveActiveBinding:450 ]- NODE 14: Got a value event from Z-Wave network, endpoint = 0, command class = ALARM, value = 0
2015-11-30 21:49:30.337 [DEBUG] [ApplicationCommandMessageClass:85  ]- Transaction not completed: node address inconsistent.
2015-11-30 21:49:37.015 [DEBUG] [eController$ZWaveReceiveThread:1528]- Receive Message = 01 0C 00 04 00 13 06 31 05 04 22 00 6B 9B 
2015-11-30 21:49:37.016 [DEBUG] [eController$ZWaveReceiveThread:1452]- Receive queue ADD: Length=1
2015-11-30 21:49:37.016 [DEBUG] [b.z.i.protocol.ZWaveController:1210]- Receive queue TAKE: Length=0
2015-11-30 21:49:37.016 [DEBUG] [o.b.z.i.protocol.SerialMessage:233 ]- Assembled message buffer = 01 0C 00 04 00 13 06 31 05 04 22 00 6B 9B 
2015-11-30 21:49:37.016 [DEBUG] [b.z.i.protocol.ZWaveController:1211]- Process Message = 01 0C 00 04 00 13 06 31 05 04 22 00 6B 9B

My item is configured the following way, and gets updated to a 0 when the alarm triggers.
Number alarm_brann_ko "Brann kontor [%.0f]" (alarm, brann, kontor) {zwave="14:0:command=ALARM" }

When the alarm finally goes silent, the following appears in the log.

2015-11-30 21:50:06.813 [DEBUG] [b.z.i.protocol.ZWaveController:190 ]- Message: class = ApplicationCommandHandler (0x04), type = Request (0x00), payload = 00 0E 0A 71 05 00 00 00 FF 01 00 01 02 
2015-11-30 21:50:06.813 [DEBUG] [ApplicationCommandMessageClass:38  ]- NODE 14: Application Command Request (ALIVE:PING)
2015-11-30 21:50:06.814 [DEBUG] [ApplicationCommandMessageClass:56  ]- NODE 14: Incoming command class ALARM
2015-11-30 21:50:06.814 [DEBUG] [z.i.p.c.ZWaveAlarmCommandClass:82  ]- NODE 14: Received Alarm Request
2015-11-30 21:50:06.814 [DEBUG] [z.i.p.c.ZWaveAlarmCommandClass:94  ]- NODE 14: Alarm report - Value = 0
2015-11-30 21:50:06.814 [DEBUG] [z.i.p.c.ZWaveAlarmCommandClass:112 ]- NODE 14: Alarm Type = General (0)
2015-11-30 21:50:06.814 [DEBUG] [b.z.i.protocol.ZWaveController:682 ]- Notifying event listeners: ZWaveAlarmValueEvent
2015-11-30 21:50:06.814 [DEBUG] [.z.internal.ZWaveActiveBinding:433 ]- ZwaveIncomingEvent
2015-11-30 21:50:06.814 [DEBUG] [.z.internal.ZWaveActiveBinding:450 ]- NODE 14: Got a value event from Z-Wave network, endpoint = 0, command class = ALARM, value = 0
2015-11-30 21:50:06.815 [DEBUG] [ApplicationCommandMessageClass:85  ]- Transaction not completed: node address inconsistent.
2015-11-30 21:50:08.906 [DEBUG] [eController$ZWaveReceiveThread:1528]- Receive Message = 01 0C 00 04 00 0E 06 31 05 01 22 01 11 F8 
2015-11-30 21:50:08.906 [DEBUG] [eController$ZWaveReceiveThread:1452]- Receive queue ADD: Length=1
2015-11-30 21:50:08.907 [DEBUG] [b.z.i.protocol.ZWaveController:1210]- Receive queue TAKE: Length=0
2015-11-30 21:50:08.907 [DEBUG] [o.b.z.i.protocol.SerialMessage:233 ]- Assembled message buffer = 01 0C 00 04 00 0E 06 31 05 01 22 01 11 F8 
2015-11-30 21:50:08.907 [DEBUG] [b.z.i.protocol.ZWaveController:1211]- Process Message = 01 0C 00 04 00 0E 06 31 05 01 22 01 11 F8 

Like others in this thread, my problem is that the I am unable to differ between the two events since the value of the ALARM command class is 0 in both events.

Testing another Fibaro alarm device (FGFS-101 Flood Detector), i have no problems detecting the different alarms (value 255).

2015-11-30 22:55:38.472 [DEBUG] [ApplicationCommandMessageClass:38  ]- NODE 20: Application Command Request (ALIVE:PING)
2015-11-30 22:55:38.472 [DEBUG] [ApplicationCommandMessageClass:56  ]- NODE 20: Incoming command class SENSOR_ALARM
2015-11-30 22:55:38.472 [DEBUG] [c.ZWaveAlarmSensorCommandClass:85  ]- NODE 20: Received Sensor Alarm Request
2015-11-30 22:55:38.472 [DEBUG] [c.ZWaveAlarmSensorCommandClass:104 ]- NODE 20: Alarm Report: Source=20, Type=General(0), Value=255
2015-11-30 22:55:38.473 [DEBUG] [b.z.i.protocol.ZWaveController:682 ]- Notifying event listeners: ZWaveAlarmSensorValueEvent
2015-11-30 22:55:38.473 [DEBUG] [.z.internal.ZWaveActiveBinding:433 ]- ZwaveIncomingEvent
2015-11-30 22:55:38.473 [DEBUG] [.z.internal.ZWaveActiveBinding:450 ]- NODE 20: Got a value event from Z-Wave network, endpoint = 0, command class = SENSOR_ALARM, value = 255
2015-11-30 22:58:56.861 [DEBUG] [ApplicationCommandMessageClass:38  ]- NODE 20: Application Command Request (ALIVE:PING)
2015-11-30 22:58:56.861 [DEBUG] [ApplicationCommandMessageClass:56  ]- NODE 20: Incoming command class SENSOR_ALARM
2015-11-30 22:58:56.861 [DEBUG] [c.ZWaveAlarmSensorCommandClass:85  ]- NODE 20: Received Sensor Alarm Request
2015-11-30 22:58:56.861 [DEBUG] [c.ZWaveAlarmSensorCommandClass:104 ]- NODE 20: Alarm Report: Source=20, Type=Flood(5), Value=255
2015-11-30 22:58:56.862 [DEBUG] [b.z.i.protocol.ZWaveController:682 ]- Notifying event listeners: ZWaveAlarmSensorValueEvent
2015-11-30 22:58:56.862 [DEBUG] [.z.internal.ZWaveActiveBinding:433 ]- ZwaveIncomingEvent
2015-11-30 22:58:56.862 [DEBUG] [.z.internal.ZWaveActiveBinding:450 ]- NODE 20: Got a value event from Z-Wave network, endpoint = 0, command class = SENSOR_ALARM, value = 255
2015-11-30 22:58:56.862 [DEBUG] [ApplicationCommandMessageClass:85  ]- Transaction not completed: node address inconsistent.

Hi,

I’m also trying to make FGSD-002 works with OpenHAB, and I get the same issue: only ALARM=0 when manually raising an alarm.
I’m using a ZWave Plus controller (Aeon Labs).

Is someone able to make it work?

Thanks for your help.

Hi,

After many tries, I was able to receive alarms by adding “respond_to_basic=true”. And by adding controller in Group 2 & 4.

According to Victor’s previous message, it is not the “ZWave plus” way to do, but openhab seems to lack some compatibilities here…

Hi,

I have the Fibaro, too. And I tried very much, thinking that I am doing something wrong. Then I ordered a test spray (http://www.amazon.de/LogiLink-Rauchmelder-Test-Spray-150-RP0011/dp/B00IFBFY8E/ref=sr_1_1?ie=UTF8&qid=1458417059&sr=8-1&keywords=rauchmelder+test+spray), used it for one second and got alarms on several ways (every hint I got in this forum).

Thus, you NEED a test spray to get an alarm.

Hi,

I already have a test spray. And it is only working with “respond_to_basic” configuration in my case.

Hi,

in my system this item definition gets executed without respond_to_basic

Switch Fire_Detector_1_SmokeSwitch2b "Sensor Alarm Type 1" (gSmokeDetectors) { zwave="25:0:command=sensor_alarm,alarm_type=1" }

Hi,

The only difference I have with your config is the ‘:0:’ you have after node id.
I can’t make a test right now (my children are asleep), but do you know what does it mean ?

Lionel

Hi Lionel,

this is the endpoint. Normally you do not need this, but I was desperated and tried a lot. :slight_smile:
See here: https://github.com/openhab/openhab/wiki/Z-Wave-Binding#item-configuration

But this is not the right way. I only have one smoke sensor yet and am playing in a test scenario. To add respond_to_basic is the solution.

I’d like to share my experience with this sensor that I’m using with a z.wave.me usb stick, so with zwave plus support.

This is my configuration:

Sincerely before to get the green light I had to wake up the sensor several times.
I couldn’t figure out why the Basic ON frame value is -1, even if I change it to the default value (255) it goes back to -1.

Anyway I was able to get values from all the following items:

Contact ZWaveFibaroSmokeDect "Corridor Smoke Dect [%s]" (ZWave, SmokeDetector) {zwave="2:command=sensor_alarm,alarm_type=1" }
Contact ZWaveFibaroSmokeDect_Heat  "Corridor Heat Dect [%s]" (ZWave, SmokeDetector) {zwave="2:command=sensor_alarm,alarm_type=4" }
Contact ZWaveFibaroSmokeDect_Tamper  "Corridor Smoke Dect Tamper [MAP(en.map):%s]" (ZWave) {zwave="2:command=sensor_alarm,alarm_type=0" }
Number  ZWaveFibaroSmokeDect_Battery  "Corridor Smoke Dect Battery level [%d %%]" (ZWave) {zwave="2:command=battery" }
Number  ZWaveFibaroSmokeDect_Temp  "Corridor Smoke Dect Temp [%d°C]" (ZWave) {zwave="2:command=sensor_multilevel,sensor_type=1" }

And as others here I got CLOSED status for the three alarm type items.

According to the manual there are 5 association groups available:

1st group – Lifeline. Reporting device state. Only one device - Z-Wave network
controller may be set in this group. It’s not recommended to modify this association
group.
2nd group – Fire Alarm. Sending the BASIC SET control command once smoke is
detected. Its value may be modified in advanced parameters (see section XVII). Group
may control up to five on/off devices.
3rd group – Tamper. Sending the notification NOTIFICATION REPORT (TYPE =
BURGLAR, EVENT = PRODUCT COVERING REMOVED) to associated devices once
enclosure opening is detected. Up to five devices supporting enclosure opening
command (NOTIFICATION REPORT) may be included in this group.
4th group – Fire Alarm. Sending the notification ALARM SENSOR REPORT (TYPE =
SMOKE ALARM) to associated devices once smoke is detected. Up to five devices
supporting fire alarm command may be included in this group
5th group – Tamper. Sending ALARM SENSOR REPORT notification (TYPE =
GENERAL) to associated devices once enclosure opening is detected. Up to five devices
supporting SENSOR ALARM REPORT command may be included in this group.

So I associated of course the 1st group with the controller, and than since my alarm items are mapped on sensor_alarm command class I associated also and only the groups 4 and 5.

The tamper item worked successfully at every case opening.

I decided to make a smoke self test pushing the center button for 10 seconds and keeping the sensor between two pillows (thank you @roher :wink:) and I didn’t see any change in the smoke alarm item, but as reported from the support during the self test no alarm command is sent, that’s also according to the manual:

When the self-test is triggered manually the Fibaro Smoke Sensor
sends control command to the Z-Wave network controller and to
1st Association group devices.

As reported above the 1st group is only used to report status to the controller.

So I decided to make a real smoke test and I used an incense stick before to buy a testspray and it worked! The sensor detected the smoke and I saw the ZWaveFibaroSmokeDect item going from CLOSED to OPEN and back to CLOSED and my rule triggered successfully.

That is great news, thank you for sharing!

Hi Guys,

I am also trying to get my FGSD002 to work properly. I have defined smoke, heat, tamper, battery and temperature as items and this is what I get (without any map transformations):

Heat: CLOSE
Smoke: CLOSE
Tamper: OPEN
Battery: 100%
Temperature: -

Heat & Smoke seems to be ok with the state “CLOSE”. Have you guys mapped this to “smoke/no smoke” and “Fire/No fire”)? Battery also seems to work fine.

But I’m not sure about Tamper! Why does the sensor report “OPEN”? Is this the regular state? It makes more sense that this should also be “CLOSED” (as the sensor of course isn’t open!).

And finally Temperature: No value is reported (yet). Maybe this is because the temperature hasn’t changed more than 1 degree (as this is the configuration default). I will monitor this the next days to see, if this is the case or if there is another problem with the temperature report.

Hi,
actually I have the value CLOSE from the Tamper item, and I verified that when I open the case the value changes to OPEN.
You can change the parameter 21 about the temperature range difference reporting, just to make sure you receive the values you can set the minimum allowed 0.1 (so you have to type 1, it is multiply by 0.1).