Rules Not Executing After Reboot

Hey OH community.

I am seeing an odd behaviour that I wanted to see if others have seen this.

So I am somewhat new to OH but picked up on this quickly and ported all my devices off of my Wink to the OH with ease for the most part.

One odd thing I have noticed is around the Rules Engine. I have created event based rules to turn my lights on (at Sunset via Astro Binding) and then off at a set time (11pm).

The rules execute fine most of the time. However I started to notice that intermittently they would not execute on the event or times I specify. It took me a couple of weeks to find the pattern here.
This is where it gets interesting.

When my OH RaspPi has restarted, be it at my own hand or because of a power outage, moving it, etc. The rules will not execute as expected.
To make them work again, I simply open the rules and save them. Without making any changes to the rules what so ever.
Then they start working fine again, as expected. Until the time comes when the system is rebooted.

Has anyone seen this behaviour before or know of a resolve for it?

Super confused.

Are you using the experimental rules engine, edited from PaperUI? (as opposed to text xxx.rules files)

1 Like

Hey @rossko57 Thanks for the reply.
I am using the Experimental Rules engine via PaperUI.

More on the known issue here
Try the suggested workround - disable all rules, reboot, enable
There is a fix but you might prefer not to use snapshot releases.

Thx @rossko57 for that.

In reading though that thread, it wasn’t clear to me if the disable/reboot/enable trick was a permanent fix or if it would come back once I reboot/power cycle my OH.

As mentioned, I am somewhat new to OH but would be willing to try a snapshot if it was stable enough. As long as I have a backup I can restore to if things go too wrong.

So just an update on this.
I followed the instructions and did the disable/reboot/enable procedure, except there was one issue I ran across. After rebooting, the rules were all enabled again by default and were not working.

I tried to disable and re-enable them to see if it would bring them back to life but they still were not working until I went into the edit screen and saved them again.