Rules not working after reboot

  • Platform information:
    • Hardware: raspberry pi 2
    • OS:
    • Java Runtime Environment: java version “1.8.0_161”
    • openHAB version: v1.8.3
  • Issue of the topic: I had a power cut the other night and OH got shut down, since then I cannot get rules to run. Looking at the log the startup gets to loading rules and doing astro calculations then stops and does nothing. MQTT devices are controllable but not rules work.

I have had this same issue before and fixed it by reboot over and over again until it ‘fixed’ it self.
I have no idea where to start with debugging this.
I have deleted all rules and add ons, then readded all. (this didn’t work, but i didn’t expect it to as the only thing which had changed, and caused the issue is the reboot).

My OH system has been running for over 30 days non stop without any issue until this power cut.

any assistance is appreciated.

A power cut on a Raspberry often crashes the sd card.
Do you have any spare lying around? Worth a try …

Just to be specific, it doesn’t crash the card so much as it corrupts the file system. A reformat of the SD card will result in a good working card again. It’s a subtle but important difference.

Thx, that is what I tried to say … unsuccessfully :grin:

Just after I posted this message I restarted again 2 more times and the second time it fixed it.
Cant be the SD card corruption issue as its fixed now.

Any other ideas?

Can tell much without logs: OH and your OS

What logs do you want to see? the /var/log/openhab/openhab.log file really doesn’t show much. Just what I have already told you.

OS: Linux raspberrypi 4.1.13-v7+ #826 SMP PREEMPT Fri Nov 13 20:19:03 GMT 2015 armv7l GNU/Linux