Running VS Code slows down openhab

I have realised that when running VS Code the openhab instance is slowed down. The rule checking is also taking forever. When typing code in rules it takes long to evaluate, picking each typed character separately.
I see it in the log that it reevaluates syntax on each typed character.
Is my setup wrong. I am running 2.2 stable.

What VSC-version and oH-extension?

This is a known issue/bug

Edit:
I pushed the issue and linked this thread, to get it back in mind for the repo maintainers.

VSC hasn’t changed since Nov last year, is OH-extension is that one of 2.2 stable. Possible install a newer one?


Having all tools been updated is always best practice of course,
but i doubt that it will solve this problem.

The problem is on server side in eclipse smarthome (see my link above) and has to be solved there, which obviously hasn’t happened yet.
(So in fact, you can’t do much on your own here, except of fixing the bug in eclipse smarthome.^^)

I have not checked for updates for the addon

My vs code has updated a few times where do I check for updates is it done with vs code?

hc_294

Are there any solution to fix this problem?
I have also the problem that my openhab slows down when I’m editting rules via VS Code.
It is very slow…

For me, I disabled all build-in extensions in addition to the installed ones, and it becomes better. Maybe this can help you as well.

Resurrecting an old thread but I’ve now linked my performance problems (well, OH - doctor says new meds should fix mine) with VS Code.

with more frequency OH slows to a crawl. Parsing files takes - at times - a couple of minutes. Rule execution (to start the rule) is very slow.

When this happens htop shows one of the cores pegged (RPi 3B+). It’s not a hung process as it moves between cores but nonetheless, keeps one pegged.

My only ever solution was to restart the service.

This morning the same had happened. Closing VS code stopped the problem. Starting it again caused it to come back.

Without VS:

with VSCode (running while typing this)

Seems to be no difference between VSCode with open files and VSCode with no open files.

It seems to drag down the whole platform.

The Problem is that Language Server running on the OH slows everything down.
I found the solution in installing a separate node for just running the Language Server


This doesn’t make the VSC working faster, the production node is working without any side effects.
You may try use samba for sharing the folders which may solve the refresh problem.

Interesting you did that. I was thinking along those lines.
I have a FreeNAS server, I can run OH in a jail there as a slave. Would be far more performant than another RPi.

How does the slave instance not fire the rules though?

You do not install the bindings on that helper node, you do not need them. Through the jsondb you just jet the thing/item defs