Runtime update from ESH?

Hi @kai,
I was wondering if you can update the OH2 snapshot from the latest ESH core? It’s been about 6 weeks (looking at the date on the files in my dev environment anyway) since the last update and there are quite a few updates that I’d like to work with :smile:.


Hi Chris,

You can always check and you will see that the last stable release was done yesterday.
If your workspace version is too old, try to re-resolve the target platform - it should pick up the new versions.
Cloudbees also already correctly picked up yesterday’s version:


Hmmm - ok, thanks. I did try to update the target, but the JARs still looked old… I’ll have a play…


I didn’t check the errors before (just hit the reload button) but if I go into the target editor, I get the following errors when I reload the target…


Can you let us know if those update are needed for the zwave binding? You mentioned some missing functionalities in this post

No - the issue is not yet addressed.

To cause a proper re-resolution, you need to open the target file with the text editor and increment the sequence number in the header. This will trigger PDE to check all update sites for new versions.

So, I updated the following line -:

<target name="openHAB 2 Target Platform" sequenceNumber="142">

I change the number from 141 to 142 - I assume this is what you mean?

I then tried to refresh the target - the result was the same. I then restarted Eclipse, and now all ESH dependancies appear to be removed. If I go to the target editor, then the errors above are there and the target is now showing with a red cross :frowning:

I’ve also just tried to “Perform setup tasks” but that hasn’t helped either… If I look in the debug config, I have no plugins listed from the target - only the workspace.

The error I get in the target is the same as above… It looks like incrementing the sequence number cleared the target, but it still can’t load the new target…

Yes, this is what I mean. It usually directly triggers a tp resolution and in the tp editor you should see the resolved update sites once the job is done. Does it still show the same error as from your screenshot above? Does it at all run the background job at all (should take a few minutes)?

I don’t think the TP update ran in the background - it showed a dialog showing all the dependancy updates. When I did the setup task rerun, that did run in the background and I then restarted…

Currently I have the same error as per my screenshot above - except now that I’ve purged the old TP from August it’s a permanent error…

I’ve restarted Eclipse a couple of times, but it’s not resolved itself…

I’ve resynced everything and it seems to have sorted itself out now - not sure what the issue was, but it’s cleared…


Glad to hear, because I was out of good ideas :wink: