Samba access to OpenHABian from Windows 10

Having access to everything increases the likelihood of unintentionally breaking things so I prefer this for beginners (pros will usually work on the system itself anyway).

I do not agree as a beginner I will not remember what you have to do or what you have done in the last 6 months. It is just a matter of approach. You can find everything what you need in this folder or you have to map each folder manually.

Can you please add hint how to edit /etc/samba/smb.conf if to do it?

Then anybody including many beginners would possibly do that right away. That would invalidate the philosophy.

Sure, you just need to login via SSH and then edit the file. You can do this with the Nano text editor:

sudo nano /etc/samba/smb.conf

Then scroll down to the section with the Custom Share Definitions. You will find the entry already prepared at the top of that section but by default it is inactive and you need to uncomment these lines by removing the leading “;” (highlightened in yellow colour in my screenshot):

grafik

After that save the file and you’re done.

1 Like

Vossi I am thankful that somebody can help to end this thread. The worse case is when you are reading all through and there is no conclusion even if you know that this is the correct thread for you.

Thank you!

Then just mark it as solved :wink:
grafik

Hello, I have tried everything on this thread to no avail. Just wondering how my hardware should be set up. I have a windows 10 PC from work, i have sufficient admin privileges, i have a RP4 with openhabian 3.2 installed. i have enables wifi on the RP4. my laptop was connected directly to my SP router/modem and so was the RP4, and i couldn’t get it to work, samba sharing settings in the router are enabled. i also tried ethernet cable connection via TP-link ethernet over power, didnt work. Tried connecting the RP4 and laptop to the wifi of the TP-link EoP and it didnt work, but i have no issue connecting to http://openhabian:8080/ to change anything, putty works to connect to the RP4 also. just cannot connect to the RP4 share by mapping the drive or using VSC with the Openhab extension.

Post 32 above talks about enabling SMB 1.0. Is that enabled on your PC ? Because of security I assume the default is that it’s disabled.

Hi Wolfgang_S, i have tried everything in this thread, probably tried everything 5 times, enabling and disabling, uninstalling Samba, reinstalling Samba, enabling/disabling/reenabling SMB 1.0. and on and on and on, still no luck
Cheers for the suggestion

is not so much description about if you get an error message or not.
What do the logs that are located in /var/log/samba show ?

I dont have access to the directory, the following is shown
-bash: cd: samba: Permission denied

get a root shell first: sudo bash

Thanks for that. All the files including the log files in the /var/log/samba directory are empty

For the moment then I would conclude that either
a) log level is not high enough => increase to get more verbose information about the problem
or
b) the service is not running

In my environment at least log.nmbd gets an entry added every 15 minutes.

I had the issue that I could not connect to the shares from OSX and what solved it for me in the end was to set a SMB password with:

sudo smbpasswd -a <user_name>

After that I could access all shares with my user/pass