Samba/Network Issue

I have OH2 installed on my RPi3. It recently crashed and I had to rebuild everything. I reflashed my SD card and went through the setup and have a fixed IP assigned. I can connect fine through Paper UI.

The Pi is connected via Ethernet cable directly to my Router.

My desktop machine (Windows 10) is also directly connected to the same Router and I can PuTTY into the RPi3 from my desktop. However, when I open File Explorer, it does not show up as a network drive.

I can, however, access my RPi3 from my laptop (also running Windows 10) which is wirelessly connected to the same Router to which my Pi and Desktop are connected. I don’t want to install SmartHome Designer on my laptop since I use my laptop mostly for work.

Any suggestions on why my desktop can’t see the Pi in File Explorer?

Thanks in advance!

do i understand that in your desktop you do not see the samba shares, but in your laptop you do see the samba shares?

Yes, exactly.

is it in the correct workgroup?

Workgroup in samba config is set to “WORKGROUP”.

ok but what is the workgroup of your Windows machines?

Are you talking about a "Homegroup? Neither my laptop, nor my desktop are in a Homegroup. Both machines do have Network sharing on though.

No, I specifically mean a workgroup:
go to Control Panel\System and Security\System and check the name of your workgroup

Sorry, yes. Both computers use the Workgroup of “WORKGROUP”.

That is too bad :slight_smile: but one of the most frequent causes now ruled out
Just tomake sure: the desktop, before you were rebuilding your OH, did that desktop see the samba shares correctly?

Did you recently do an update of your desktop machine? Windows10 recently employs a new Samba protocol that breaks Linux compatibility
In the mean time you may check here, where a similar problem is described

Maybe caching problem… but you should be able to reach the RPI by typing the url manually in windows file explorer: \\openhabian\openhab2-conf\ or \\raspberry-ip\ and from this point, use the file browser…


This worked!! Thank you! I would have never thought to try this!

Any idea how I got this issue or how to prevent it?

1 Like

I’m afraid not!
I’m running samba as a wins server, and sometimes I get windows network detection up and working when restarting samba, but this feature of windows never worked flawless to me, with or without the wins server.

1 Like

Thanks for your help, I appreciate it SO much!!

very true

In case anyone else has problems, my issue was a policy that was applied by the Windows Creators update. I fixed it by changing group policy settings:

Computer configuration\administrative templates\network\Lanman Workstation
“Enable insecure guest logons”

More details from Microsoft here:

1 Like

Had the issue and spent 3 hours fighting…

I’m on Windows 10 v.1803 (for now).
I couldn’t see the \openhabianpi on network, but could connect via IP: \
But even when trying to access any shared folder, none of credentials worked. Changing passwords, using openhabian-config… nothing…

But finally found the method:

Edit /etc/samba/smb.conf and add in [global] section

ntlm auth = yes

Restart Samba:

sudo service smbd restart

And everything worked instantly…

1 Like