Samsung TV: Setting volume stops working after a while

Hi all,

I am using the current version of openHAB / 3.2 Milestone Release with a 2018 Samsung TV (Q7FN).
Since openHAB 2.x controlling my tv did mostly work. Binding 3.2.0.M3 is configured to use secure websockets. I control everything via Alexa.

My item config:

Dimmer samsungVolume       "Fernseherlautstärke"    (tv_endpoint)  {alexa="Speaker.volume", channel="samsungtv:tv:158772a7_34e7_4594_bda5_2f8b081e8387:volume"} 

Recently, setting volume of the TV stops working after a short while.
Other binding commands keep on working, e.g key_commands for switching between hdmi inputs or power on and off the tv. It is volume control that stops working.

Whenever i restart openhab, setting the volume works as expected.
Then suddenly it stops working.
For example, if i tell Alexa to set the “Fernseherlautstärke” (tv´s volume) to “6”, the following is loggd in the openhab event log:

2021-11-14 18:51:16.236 [INFO ] [openhab.event.ItemCommandEvent      ] - Item 'samsungVolume' received command 6
2021-11-14 18:51:16.236 [INFO ] [penhab.event.ItemStatePredictedEvent] - Item 'samsungVolume' predicted to become 6
2021-11-14 18:51:16.240 [INFO ] [openhab.event.ItemStateChangedEvent ] - Item 'samsungVolume' changed from 0 to 6

But in the openhab.log output a warning is logged, and setting the volume does not work:

2021-11-14 18:51:16.246 [WARN ] [rnal.service.RemoteControllerService] - 192.168.xx.xx: Remote control: wrong command type 6 channel volume

I tried different versions of the plugin, configuration by file or by UI, behaviour does not change.
What can i do? Help would be greatly appreciated, as the binding is fantastic. Thanks to the author!


When i restart openHAB and try, again, it works temporarily:


2021-11-14 20:29:15.473 [INFO ] [openhab.event.ItemCommandEvent      ] - Item 'samsungVolume' received command 7
2021-11-14 20:29:15.474 [INFO ] [penhab.event.ItemStatePredictedEvent] - Item 'samsungVolume' predicted to become 7
2021-11-14 20:29:15.480 [INFO ] [openhab.event.ItemStateChangedEvent ] - Item 'samsungVolume' changed from 0 to 7

At this time, there are no entries in openhab.log.

But soon it stops working again.

I also have this issue with my UE40ES6570. It works sometimes to either restart the bundle or to cut off the tv from the power supply.

Hi all,

Problem is solved by installing the snapshot verison of the samsung tv binding by Nicholas_Waterton.
Important: For installing bindings manually, first the current active / bundled version needs to be uninstalled! Afterwards place the manually downloaded binding in the addons folder. If you do not uninstall the bundled binding, the one in the addons folder will be (silently?) ignored.


Hi @openhab_openhab and @Nicholas_Waterton

AWESOME! You guys are perfect!

Thanks a lot, raises our WAF massively. Really appreciate it