[SamsungTV Binding] Cannot find TV (model MU7005)

Hey everyone!
I’m new here, but I’ve been using Openhab for a couple of years now ^^ I’m writing this post because I’m at my wits and I’m not sure what else to try. Sorry for the long wall of text, but it’s a couple months of work here. Please let me know if I forgot to add anything important - I’ll update it!

Long story short Openhab v2 used to find the TV (Samsung 55" model MU7005 ). For several reasons I reinstalled the binding a few times and the binding stopped picking up the TV.

First, my setup:

  • Openhab v2.5.8 running on Docker; ( openhab/openhab:latest)
  • Ubuntu Server 18.04; (Is hardware relevant? It’s an i7 4770k with 16 gigs of ram, all on an samsung 120gig ssd 840)
  • TV connected via wi-fi (unifi AP);
  • Unifi Aps are connected to an Asus router (RT-68U);
    (If I’m missing anything please let me know!)

Things I’ve tried, after reading a whole truckload of other threads, everywhere I could find them:

  • Reinstalled Binding several times;
  • Fully wiped the tele (everything. including the dongle thingiemajig.)
  • Checked the unifi controller, in case it was throwing a fit. Made sure upnp was on in both unifi controller and the router.
  • Manually added Thing through Paper UI with correct IP and Mac address; Thing stays as “Not Found”;
  • Manually added Thing through .thing file, same as above.
  • Checked Binding Logs: Error samsung TV “Interface set as None” - I couldn’t find anything about this one, any hints?
  • When I set the log into trace mode (with the thing added on the .thing file) I get constant information about the channels, but nothing about finding the TV…
  • Added all related ports (50000, upnp) to the ubuntu firewall clearance;
  • Turned off UFW on the server all together;
  • Turned off Pihole (I know… I’m getting desperate here!)
  • Deleted my docker image from the system and downloaded a new one; (I really don’t want to do this again… :frowning: )
  • Updated docker image from 2.5.4 to 2.5.8 just now - No change.

I’ve exausted all my knowledge and I don’t know what else to try outside of a system reinstall, which I also would rather not do…

Things I know:

  • It worked until dumb ass me decided to unsintall and reinstall the binding a whole bunch of times;
  • As soon as I installed Home Assistant (docker as well), it picks up the TV - this rules out any weirdness in my network, yes?

At this point the only other test I could do is to pick up an old laptop and install openhab on it to check if it finds the god damned tv but… I already know OpenHab used to find it. That would just prove what I already know - I have a problem somewhere.

Can anyone point me in another direction? Anything I may be missing?

Did you try to stop openhab and clean the cache ?
The command is: openhab-cli clean-cache

1 Like

I haven’t no. I assumed restarting a new image would mean the same, but I’ve just noticed that I never actually deleted the cache in the user folders… hmm.
I’ll give it a whirl after work and report back. Thank you!

Hmm that command does not exist in my docker installation, nor does it work in karaf.
By cleaning cache what folders do you mean the Tmp and cache folders? I found those in my user data files. Shut down open hab docker container, empty those two folders, restart container - is this correct?

Edit: Update, no change.
Deleted both the cache and the tmp folders located in the userdata folder. The locations of the files are different because it’s a docker container, but I couln’t find more openhab data anywhere else.
I stopped the container and everything just to be sure.

Any further hints?