SamsungTV binding only opens ipv6 1900 for upnp



Somewhere at four or more weeks ago I lost control of my samsung TV’s with Samsung TV binding. Right now I have some time to investigate and I’ve found that the binding is only listening on :::1900 udp6 (netstat). I reinstalled, emptied cache, restarted oh3 with docker-compose, etc. and ipv4 :1900 does not come up.
I installed another fresh instance in windows and it can find my samsung TVs and listens on both ipv4 and ipv6. So this is definitely not a binding bug itself.

IPV6 is disabled in openhab network settings, I bound openhab to my ipv4 address directly all from webUI. Docker has no ipv6 support enabled. Docker OS is Ubuntu Server 21.10 with working ipv6 itself but one of my samsung TV has no IPv6 support at all (older than 2014). Devices can be discovered from Ubuntu OS as well with gssdp-discover (from gupnp-tools package). Same discovery is working from docker container itself - it should not if samsung binding binds to ipv4:1900 port. OH3 is started in network:host mode in docker. This is OH-3.2.0.

So what to do next?

Thank you,

The solution was in the thread below. I think the default limiting factor was the pools. I have a lot of upnp devices in my home network (especially since jellyfin was started) and there was no pool for ipv4 port bindings. Unlimiting the pools the binding started to work as expected.