Satel Bindings IO Errors

OH2, Satel 1.9.
Java errors in log - after connected to ETHM-1 I receive IO error:
End of input stream reached
Fresh installation of openHABian all updates installed.
Same result I get from OH 1.x and Satel binding 1.8.x + replaced US_export_policy and local_policy.

Any ideas what I haven’t set up?


Could you open a detailed issue, including all configuration and logs, expected result, and problem here:

Sure, ust right now I’m going thru my Satel/ETHM configuration to be sure it isn’t my mistake. So far I get same result for OH 1.8 and OH 2.0 (2.0.0~20161229034207 (Build #682)).

Hey @adrych,
This kind of error might be coming from fact that ETHM does not accept socket connection or your integration password is wrong. Be aware that satel binding allows to specify two “passwords”, one is for binding itself to safely communicate, second is to authenticate user with satel system.

I used to have same issue before but after syncing up configurations (DloadX is quite unintuitive to me) it went away.

Hi @splatch

Thx. I have same password phrase for both. Anyway, I’ve forgotten attach openhab.log to my first post. Sequence is repeating all the time. Same error in OH1.8 and OH2.0
Part of the openhab.log:

2016-12-29 13:49:34.358 [INFO ] [.satel.internal.protocol.Ethm1Module] - Connecting to ETHM-1 module at
2016-12-29 13:49:34.377 [INFO ] [.satel.internal.protocol.Ethm1Module] - ETHM-1 module connected successfully
2016-12-29 13:49:34.518 [ERROR] [.satel.internal.protocol.SatelModule] - Unexpected exception occurred during reading a message End of input stream reached at org.openhab.binding.satel.internal.protocol.Ethm1Module$EncryptedCommunicationChannel.readMessage(
[204:org.openhab.binding.satel:] at org.openhab.binding.satel.internal.protocol.Ethm1Module$EncryptedCommunicationChannel.access$0(
[204:org.openhab.binding.satel:] at org.openhab.binding.satel.internal.protocol.Ethm1Module$EncryptedCommunicationChannel$
[204:org.openhab.binding.satel:] at org.openhab.binding.satel.internal.protocol.SatelModule.readMessage(  
[204:org.openhab.binding.satel:] at org.openhab.binding.satel.internal.protocol.SatelModule.communicationLoop(
[204:org.openhab.binding.satel:] at org.openhab.binding.satel.internal.protocol.SatelModule.access$1(
[204:org.openhab.binding.satel:] at org.openhab.binding.satel.internal.protocol.SatelModule$CommunicationWatchdog$
[204:org.openhab.binding.satel:] at[:1.8.0_111]
2016-12-29 13:49:34.525 [INFO ] [.satel.internal.protocol.Ethm1Module] - Closing connection to ETHM-1 module

As You can see bindings connect to ETHM-1 but then get more than expected… Not sure my fault or bindings.
And regarding DloadX - it isn’t most intuitive tool :frowning:


Hi @adrych
To me it also looks like wrong configuration. First of all you have configured port 7092, while default one for integretion purposes is 7094. Double check you have correct port configured.

Second thing is encryption password. I would start with unencrypted connection, with commented out encryption_key setting in OH configuration. If this works, double check your encryoption settings in DloadX. It is not enough to specify encryption key (“Manipulatory” page), but you also need to enable encryption (“ETHM-1” page).

Please let us know the results.

I have change default port…
Also I have upgraded firmware ETHM and Integra mainboard to the latest… Still the same result…

Did you do the rest of things I asked you to do? Again: start with unencrypted connection first, then - if it works - you can try to enable encryption.


Yes I have. Additionally I have reset ll settings at ETHM-1 and setup it
from the scratch…
Encrypted - N

After reboot I can connect to ETHM but nothing get from it. I will send
logs when get back home…

And yes- I have check all combinatins - encrypted/not encrypted with user
code without, changed port…


Ok, so I wait for the logs, please configure the binding to log DEBUG level and please send your firmware version for both Integra and Ethm-1. Also screens from DloadX would be helpful.

Double check you don’t have anything else but in all fields on “Filtr IP” page. There must be some wrong setting in the config…

I have reinstall OH and all problems solved… Thank You.

I’m happy to hear that. Enjoy! :slight_smile:

1 Like