Saving service configuration over myopenHAB fails with a timeout

After i have done my first panel configuration i now want to save it to access it from my tablet.
The problem is, that the panel configuration ist not saved successfully.
I have tried the following:

  • in Habpanel (on my computer) go to settings and click on Save the current configuration to a new panel configuration, i entered a name and cklicked on ok.
  • the configuration should now be saved
  • next I go to my tablet and try to load that configuration, but there is only the option for the local storage
  • when i now log of from myopenhab on my computer and login again, the saved configuration is also not there.

Looks like you did everything correctly… maybe the config was overwritten somehow? (this shouldn’t happen)

Can you open Paper UI then go to Configuration > Services > UI > HABPanel (Configure button) > Show more and verify you have something in the “Panel registry JSON”.
If not please try again and open the browser’s developer tools (F12 on Windows, Command+Option+J on Mac) before you click on “Save the current configuration…” for anything suspicious - there should be a line in the console like “openHAB 2 service configuration saved”.

The field “Panel registry JSON” was empty.
I fixed the problem yesterday evening. My mistake was to do this configuration via myopenhab.
When I did it while i was in my local network everything works fine and I was able to save the configuration.
I don’t know if this was a bug or it works as design and it is not possible to save configuration via myopenhab.

I was about to say “No, saving should work over myopenhab too.” but then I tried it and it fails too with:

Error while saving openHAB 2 service configuration: {"data":"<html>\r\n<head><title>504 Gateway Time-out</title></head>\r\n<body bgcolor=\"white\">\r\n<center><h1>504 Gateway Time-out</h1></center>\r\n<hr><center>nginx/1.10.0 (Ubuntu)</center>\r\n</body>\r\n</html>\r\n [...]

That happens every time.

In fact trying to save any service configuration i.e.
even from Paper UI, fails with a timeout like above over myopenhab - I don’t know whether it’s expected or not…

I’ll move this topic to the myopenHAB in the hopes it will get attention. :slight_smile:

I’ve just been caught out by this issue too. Had some partially completed code, clicked save and closed the window. Went back and it’s all gone!

1 Like

I’m also having problems saving when using myopenhab

Code changes aren’t saved when modifying widget code, dashboard modifications aren’t saved to the cloud configuration even though it says its synced.

The only error message I can get is when I try and rename an existing tab I get

Error while saving dashboards:undefined

Anyone have insights on this?

Same issue for me… Unable to config as a new habpanel when connected via myopenhab. Ok when connected locally.