Schedule Action start one hour later after Legal Time Change

Hi,
I am running OH 3.4.2 in a docker container on a Synology with parameter:

docker run \
        --name openhab \
        --net=host \
				--memory="2000m" \
        -v /etc/localtime:/etc/localtime:ro \
        -v /etc/TZ:/etc/timezone:ro \
        -v /volume1/docker/openhab/conf:/openhab/conf \
        -v /volume1/docker/openhab/userdata:/openhab/userdata \
        -v /volume1/docker/openhab/addons:/openhab/addons \
        -d \
        -e USER_ID=1042 \
        -e GROUP_ID=65537\
        -e CRYPTO_POLICY=unlimited \
        --restart=unless-stopped \
        openhab/openhab:3.4.2-debian

After legal time change last Saturday Night all scheduled rules, start one hour later. I checked time on to host:

sh-4.4# date
Tue Mar 28 22:30:46 CEST 2023
sh-4.4#

and into docket container:

sh-4.4# docker exec -it openhab /bin/bash
root@syn214:/openhab# date
Tue 28 Mar 2023 10:31:21 PM CEST
root@syn214:/openhab# date +"%Z %z"
CEST +0200
root@syn214:/openhab#

Here is my regional settings on OH it say GMT+1 Europe/Rome, but now in Italy we are GMT+2:

Clock on UI is fine:

I cannot undestand why my shedule are not running on time but one hour later.

(there is some minutes between screenshoot, but it were took in same hour)

Thanks

HI,
restarting Docker, time in now ok. It never happened when I have OH onto a Debian Box. I don’t know if it is a OH or Docker issue.

Thnaks