Security check failed while adding HomeKit

Hi, I am on openHab 3.1.0 and I can’t add it to my homekit.
The message I get from homekit is

Security check failed or action not allowed

I have tried some basic troubleshooting but could not solve. I have also tried to change the port and the PIN but it did not work. I’ve never added it before, so it’s not a conflict with a previous addition. Command log:display does not return any error for homekit or anything interesting in general.

My openHab runs on Synology with Docker and uses the host network. The homekit port is exposed as far as I can see, so it’s not reachability issue. Any more step I can try?


Hi Stefano,

where you get this message? in openhab logs?
is homekit binding running / started?
can you see openhab in home app on iphone?

Message is from Apple Home app when you scan the QR code for adding openHAB as a bridge.

I have an update. I was able to pair HomeKit and openHab.The message was misleading, but apparently my HomeKit had an orphan accessory belonged to a previous addition of openHab. I could not identify it immediately because the openHab does not come up in the list of bridges.
Accessories are correctly seen, but the bridge is not listed. Not sure this is an intended behaviour or not.

correct, openhab does not appear on the list of paired bridge. this behaviour is new, come with one of the recent ios.

still not sure how home app decide to hide bridges or not.

I see, and this explains why I thought I had removed it when I did not.
Let me know if I can help with some debug on this matter.

@LunaticMuch with latest ios 15.1.1 i can see openhab in the list of bridges in home app. can you check and confirm the same?