Seems Openhab does appreciate a restart from time to time

I have not been tinkering much with Openhab lately, it was just running uninterrupted, doing its thing, making me happy.
And then suddenly yesterday I see that a rule is getting out of line.
It needs to fire upon changing of an item and the change of that item is set by a timer in an ESP8266 (irrigation controller, not important)
Anyway: to keep it simple, it needs to fire every hour (or any other time I set).
Instead it was doing that not really in total sync with the event anymore
To be brief, everything I checked looked normal and everything I tried didnt help
This morning that rule just didnt fire at all anymore.
My best bet: just restart Openhab, so i did and everything seems OK again.
It also solved another issue: lately I had noticed values in my UI wouldnt update anymore without a reload of the page. The restart solved that too.

It is a pity that Openhab apparently accumulates some ‘issues’ while running, but I can live with a restart from time to time. We all need a break once in a while :slight_smile:

That doesn’t match my experience. openHAB has been running without issues, sometimes for months at my three locations. That said, I know of cases where it would be needed to restart, e.g. after changing a lot of things/items/groups definitions in my text-file configuration. Without changes to the configuration I did not experience any “accumulated issues”, which would be very troubling…

That is good to hear Thom. It is very well possible that it is the result of earlier ‘tinkering’.
What I will do is to keep my hands off of my openhab setup for a substantial time and see what happens.
i’ll just do the tinkering on another RPI :slight_smile: The main things I changed lately was to add icons
Nevertheless, dont get me wrong, I am quite happy with how it is behaving already and indeed if I could let it run uninnterrupted “for months/years” that would be great.

1 Like

Keep in mind that every individual installing will be different. Each binding and reach combination of bindings introduce different opportunities for subtle bugs to reveal themselves.

In short, YMMV.

I, along with others, happily run OH for extended periods of time. But there may be something about your specific combination of bindings and configs that could cause you problems. Keep an eye on it and if the problem persists start the process of elimination to figure out which binding, core, or rules are causing the problem.

1 Like

Thanks Rich, that is indeed very true

Bugs?? in my setup? impossible :wink:

For the moment I am quite happy to consider that it was my extended tinkering without at one moment saying: “Fresh start, empty cache and keep yr hands off of it”

So, will give it a try. I will keep my hands off of it for say 2-3 mo, tinker on another system and see what happens.
I do not think I have any weird or untested bindings and stuff, but you are right, maybe it is my specific combo. Could be something else I have on my RPI, which is only Webmin next to the Openhabian install.

Will report back in a couple of months, will see :slight_smile:

1 Like

Monthandahalf, left it without tinkering…still doing ok, uninterrupted

1 Like