Semantic model takes 20 - 30 seconds to load on OH 3.3

Platform information:

  • Hardware: Raspi 3 B+ (Raspian OS 10)
  • Attached Hardware: Amber Wireless AMB8465 (to read out Wireless M-Bus from water & heat meter), Aeotec Z-Wave Gen5+ (to read out power meter)
  • Docker / Portainer 2.16.0
  • openHAB Software: 3.3.0 Release Build, Persistence via InfluxDB
  • openHAB Bindings: Homematic (logging heating, controlling lights & blinds), Gardena (logging soil humidity, watering yard), Alexa, MQTT
  • Homematic IP Hardware: CCU2 (2.59.7), multiple Homematic IP devices

I’m running a (probably) pretty average openHAB installation (~60 things, ~500 items, ~30 rules). Since a couple of weeks (the precise time is hard for me to pin down), the loading time of the “Semantic Model”-page went up dramatically, usually between 20 - 30 seconds. Loading time of the “Items”-page is ~4 seconds (pretty normal I’d say).

Whenever this happens, this is what htop shows:

I found these two threads here ([SOLVED] OH3 Issue - "Model" Page endless loading - Maximum call stack size exceeded in app.js - #25 by pat281 and [SOLVED] OH3 Issue - "Model" Page endless loading - Maximum call stack size exceeded in app.js - #30 by plainspace), but they talk about endless loading, so I believe this is something different.

The loading times are similarly high when calling the “model tree” elsewhere in openHAB, e.g. when creating a new item and selecting the Parent.

Everything else appears to be working normal. openHAB log (default log level) does not show any errors. The loading times are also independent from the browser (tried on Firefox as well as iOS/Safari).

Does anyone have a clue on how to find the root cause?

Update: Rebooting the Raspi (not only the docker container) seemed to have helped (even though I tried this already before). Will continue to investigate.
Update 2: I re-deployed my entire system / docker containers (via this) and this seemed to have solved the problem (also visible in a significantly lower CPU temperature, see below).

Not sure where the problem originally came from (I started with OH 3.1 and did three updates since then), but having a fresh install of 3.4 was obviously a good idea.
Update 3: Problem still persists. Currently on OH 3.4.2.
Update 4: Lack of RAM. D‘uh…