Semantic model - UI error


I migrated to OH3 during holidays. Atm I am building up my semantic model using files.

So far everything is fine except that the UI displays the model wrong. Not always but over and over again.


Group gLaundryroom  "Laundry"  <washingmachine>  (gGroundFloor) ["LaundryRoom"]
Group  gLaundryBlinds  "Laundry Room Blinds"  (gLaundryroom)  ["Blinds"]
Rollershutter   LaundryBlinds   "Blinds Laundry"  <blinds> (gLaundryBlinds, gBlinds)     ["Blinds"]  {channel="zwave:device:....l"}

shows up in the UI:

It’s really strange and seems to me that this is a random error as the equipment that’s not displayed correctly changes every now and then.

Sometimes it helps to change the group names back and forth. But the “laundry error” persists (it popped up after a restart of OH3 without changing anything).

Have you defined any part of the Semantic Model using only the UI? That can cause unpredictable things to happen after a restart…

Also Blinds is an Equipment type, which you’ve used twice here - so you’re trying to add an Equipment to an Equipment to a Location: is that what you meant to do? It’s not wrong, but there’s no Points/Properties here.

Hi, just a guess. You have assigned the blind to two groups. Do you have the same behavior if you remove the second group temporarily?

No, only file based.
And as I wrote: the display error occurred after a restart!? Another equipment showed up wrong before but vanished.

Yes, tried that without success.

Ok. To be honest I’m just following that tutorial

Isn’t the Rollershutter a Point? How would you do it?

No, it’s not, but you haven’t defined it as a roller shutter Point either. You have used

which is an Equipment type, so openHAB will treat it as an Equipment.

Have a look at the list linked from that tutorial to see what you can use for Points.

You could maybe try ["Control","Opening"]. I don’t have a roller shutter though, so haven’t tried.

You’re right! Didn’t think about it. I’m still struggling with the semantic model.

But anyway: tried that straight away… no success

That’s odd. When the model doesn’t display right, select the equipment item then on on the right click its name to go to its page.
In “Semantic Classification” do you see a line “hasLocation: gLaundryroom” ?

Ok, we’re getting closer

Checked other equipment that is shown correctly and there “hasLocation: …” is set.
But what’s the cause? The item definitions are the same!?

I have the same issue on some of my items.
They show correctly in locations.
One of my doors has group alarm system. and laundry.
Shows only in laundry

It’s not the same issue.
An item can’t be a member of 2 equipment groups at the same time.
Only one parent equipment and/or location.

ah. gotcha.
So can be a member of multiple locations? but only one equipment?

No, at most one location, or one equipment, or both.


Follow the arrows, there can be only one relationship of each type.

I just rebooted the server again and everything seems to be fine. Even though I didn’t change anything? … I hope it lasts.


Opening this one up since @Willp indicated that in the end a root cause was not found.

I currently have exactly the same issue than described: My model consisted for some months of over 200 items purely defined in the UI, and worked perfectly well.

Then (since I had to add five identical new equipments) I defined those five equipments (with 8 channels each) via files. These five equipments first appeared correctly in the model, but then, from time to time, keep shifting to the “root” of the model. Rebooting openHAB sometimes brings it back to normal. Sometimes it helps to re-save the items-file again. Sometimes it doesn’t

What I now tried: Define also the “parent” model-item of those five equipments (locations) also via files (they were defined via UI before).

Let’s see whether this will help.