Sending specific command to Harmony Hub not working


I wanted to expand my setup by sending TV channels to my DVR. (i.e.: sending simple numbers). I have downloaded the json which contains the commands which can be sent to specific devices. It says that my Cisco DVR can receive these ones and has the following format:
0: Number0
1: Number1

However when I try to send, nothing happens. openHab receives the command, sends it, but Harmony Hub is not blinking and sending the numbers. Anyone experienced something similar? Maybe I have missed something?

Ps.: How can I send multiple numbers? Just sendCommand x2 and sending the one number after another?

Well, you do not provide too much info of what version you are running, how your rule looks like and what the log says, if the command work from the remote itself, but this is my setup that works fine:

.item (you get the channel spec from paperUI)

String KodiHarmonyCmd   { channel = "harmonyhub:device:GTV7:38930056:buttonPress" }



If you want to send, say 15, you issue the command twice


(I don’t use doble channels on the OH installation I’m currently at, so I don’t remember if I had a few ms sleep between the two. Try without first.)

This could be device dependant as well so try KodiHarmonyCmd.sendCommand(“15”). It could work.

Kodi accepts:


If you are unsure of the actual format of the string logging in to MyHarmony and checking out the commands there might provide som insight.

Thanks! It was just a dumb question…
Thing was setup through PaperUI. It works in other cases. The log didn’t provide any info, haven’t tried setting the level to debug.

My rule looks something like this:

rule “Set TV channel”
        Item TV_Channel received command ON

Have you tried simply sending “5” ?

Not yet, but I will try!

Thanks, that did the trick! But this also means, that the json file not always true!

Glad you got it working!

You need to elaborate a bit more on this one if we shall get to the bottom of this.