Senec Cloud storage can no longer be connected

Since version 4.1.0, the Senec Cloud storage can no longer be connected. The IP address is correct, I just checked again.

Hej @nohi79,

Download the Jar file and put it in the Addons folder.

Put the file in the addon directory and restarted openhab. Unfortunately no change. Is there anything else that needs to be done?

Did you remove the “official” binding?
If the new SNAPSHOT is aktiv, you will see a new setting: useHTTPS this must be true.

thanks for this fix. I have 2 questions:

  • does this jar file work on openHAB 3 also?
  • what must be set in the things file?


I Don’t know maybe @KobiP can help to answer this question.

Thing senechome:senechome:pvbattery [ hostname="<your IP", refreshInterval=15, limitationTresholdValue=70, limitationDuration=60, useHttps=true ]

this is my Thing

@kl8ter Uninstalled the binding, loaded the file from you into the addon directory, rebooted from openhab, and then enabled https. Now everything runs again!
Thanks for the great and fast help! :slight_smile:

Will this patch also be included in the next updates?

Hello everyone,
I am also interested to know, if this Version works on openHAB 3. I currently don’t have time to upgrade openHAB to version 4. But the Senec addon is one of the most important in my configuration. Therefore I would be happy to receive an answer.

Thank you all

I would just give it a try. Nothing more than not working can happen. It doesn’t work anyway :wink:

It was not working on OH3. In Karaf it was installed (not active). I decided to upgrade to OH4 which worked after installing Java 17. At a first look the binding and also all other things and items are OK.

Thanks a lot.

Any Ideas for Openhab 3.4.5. users?
I know everyone wants the OH3 users to jump onto Version 4. And I will do in a few days or weeks. But actually things worked very well.

Hi, I’m also running OH 3.4. can anybody help to fix the connetion issue. Would be great.

Thanks in advance

There is also an update for Openhab 3.x.x available.

Version 3.4.6

@kl8ter in the current version 4.1.0-M1 the fix is not yet included…

Hello Martin,

where I can download the jar-File?

Thanks and regards

Hello everyone,
in the meantime I found the link:
After I copied the jar-File into the right directory after I removed the original Addon, I can use the new Addon with the added parameter. All works fine.

Sorry, but I do not find this snapshot. The link is broken. Or is it by now included in Openhab?