Sensor Configuration (Inovelli 4-in-1 multisensor), and oddly briefly reported in celsius before farenheit

I recently purchased the Inovelli 4-in-1 multisensor, and have it correctly adopted to my z-wave network. The sensor seems to have initially transmitted celsius, and then changed to farenheit temperature data, based on the grafana data. This is for a variable I never had data coming into previously.

There is no configuration parameter for the device for Celsius/Fahrenheit, unlike the other multisensors that I have. The documentation also has an annoying comment of frustration that the temperature reporting interval variable is a derivative of a celsius unit. (I consider all non-metric units to be an abomination, in general :wink:

I have yet to hear back from inovelli about this.
My questions:
Does anyone else know of a (better) way of doing this?
Does it make sense that the sensor initially seems to have reported in celsius, then switched to farenheit? (during a time I wasn’t changing any configuration parameters whatsoever for the sensor, and kept it inside the house the entire time - just building historical data, before setting up rules)
Is it easier to do unit conversion in openhab?
For reference:

Thanks!

That Temperature channel is type Temperature which means openHAB Units of Measurement affect the readings. If you have set nothing then OH does not know what units to use. :wink:

Ah, a setting I forgot to (re) set after my unintentional fresh start.
For others, in PaperUI:
Configuration > System > Regional Settings - CLICK [Show More] - then the option for metric/imperial is shown.
Cheers

1 Like

OK, so I’ve finally come back at this one as I have the switch ready to install to control the fan with some rules. As I looked at my recent data for the sensor, I noticed that the unit change issues persist.
Every day at 9AM, the sensor records in celsius, and at 11AM, it returns to farenheit.
This is quite odd, as I have not made any rules of any kind for this sensor yet - I’ve just defined an item in my files to effectively set the retention in influxdb.

I don’t have any rules anywhere in my setup that I am aware of that change units. With all my other devices, I have set them in the device settings to output celsius. The internally (to the sensor) calculated humidity doesn’t change, so it seems it’s on something downstream of the sensor date from that calculation.

Has anyone else used these Inovelli 4-in-1 sensors to know if they’ve had any problems like this?
Any other ideas of openahb cron processes (stock, that is) that may do something like this?

Have you called the vendor support? It may be a problem within the device.

The other factor that affects UoM conversions, in addition to system/locale defaults, is your Item definition. Units that you may express in your [state presentation] section of your label get taken into account.

There’s nothing shown so far to suggest that the sensor is reporting inconsistently, or if instead the binding is auto-converting inconsistently. A debug log from the binding during your different periods should show that up.

1 Like

Thanks for the idea, @rossko57

I have gone into my items file and set up a couple additional entries to see if they make a difference, as you’ll see below. TLDR: It doesn’t:

sensors.items

Number Laundry_Temperature "Temperature [%.1f °C]" <temperature> (gTemperatureItems) {channel="zwave:device:a204e4d4:node31:sensor_temperature"}
Number Laundry_TemperatureUndef "Temperature [%.1f %unit%]" <temperature> (gTemperatureItems) {channel="zwave:device:a204e4d4:node31:sensor_temperature"}
Number Laundry_TemperatureF "Temperature [%.1f °F]" <temperature> (gTemperatureItems) {channel="zwave:device:a204e4d4:node31:sensor_temperature"}
Number Laundry_TemperatureK "Temperature [%.1f °K]" <temperature> (gTemperatureItems) {channel="zwave:device:a204e4d4:node31:sensor_temperature"}

Current temp display, all showing same number, just different unit suffixes
TempDebug

And, the unit setting for OpenHab in PaperUI (at least, what I think is the correct setting)

So, it looks like setting a unit in the item definition, the way I did, doesn’t prompt a conversion. I’m eager to hear of a fix to how I define the temperature items.

Notably, the definition is essentially identical to how I have my other temperature sensors (different manufacturers, had a parameter to set the temp to metric /C in the device configuration. All of the below sensors report temperature as I expected, in celsius.

sensors.items

Number Livingroom_Temperature "Temperature [%.1f °C]" <temperature> (gTemperatureItems) {channel="zwave:device:a204e4d4:node24:sensor_temperature"}


Number BoysBath_Temperature "Temperature [%.1f °C]" <temperature> (gTemperatureItems) {channel="zwave:device:a204e4d4:node23:sensor_temperature"}

Number Ensuite_Temperature "Temperature [%.1f °C]" <temperature> (gTemperatureItems) {channel="zwave:device:a204e4d4:node29:sensor_temperature"}


Number Mudroom_Temperature "Temperature [%.1f °C]" <temperature> (gTemperatureItems) {channel="zwave:device:a204e4d4:node30:sensor_temperature"}


Number GuestBath_Temperature "Temperature [%.1f °C]" <temperature> (gTemperatureItems) {channel="zwave:device:a204e4d4:node27:sensor_temperature"}

Any suggestions?

Why use the Number Item instead of Temperature type so the OH units of measurement can work for you?
I am on my phone and cannot post the documentation links.

1 Like

Yes, you got exactly what you asked for.
Like @Bruce says, all those Items are plain old Number types.
While it is possible to post Quantity Type values (with units) to a Number type, there will be no magic conversions. The Item itself is not a Quantity Type.

Your zwave device Thing almost certainly offers a Number:Temperature channel type, which expects to be linked to a Number:Temperature Item type.

It does. I posted that earlier in this thread 24 days ago.

After that I made the insane assumption they were using that. :thinking:

I had briefly looked into it, but then was falsely reassured I was on the right path by:
https://docs.openhab.org/v2.1/configuration/items.html (as well as several other non-documentation web sites / tutorials). When reading Bruce’s post, I hadn’t clicked that ‘Temperature’ had to be defined in the items description, and had instead latched on to needing to set my units to metric system-wide.

Number    MyTemperature  "The Temperature is [%.1f] °C"   { someBinding:somevalue }

It may be useful to update that page.

I now see the difference in:

Number:Temperature temperature "Outside [%.2f °F]" { channel="...:current#temperature" }

That was the fix. It is odd that the PaperUI-defined temperature item didn’t use the correct units after I had set the system to metric. Regardless, setting the items file definition to Number:Temperature fixed everything.

1 Like

The v2.1 is an indication that documentation was for openHAB 2.1 and was likely accurate way back then. The newer version of that -page https://www.openhab.org/docs/configuration/items.html#type mentions Temperature .

ah, forehead smack - #googlefail

1 Like

I have caught myself on that a few times. Just never posted the old link here.

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.