Serial binding other baud rates

Hey All,

just had to reinstall my windows with openhab3 on it :frowning:
so i installed the oh3 3.3.0 but the serial binding is not letting me set custom baud rate (2400)
i get

**HANDLER_CONFIGURATION_PENDING**

{baudRate=The value 2400.0 does not match allowed parameter options. Allowed options are: [ParameterOption [value="4800", label="4800"], ParameterOption [value="9600", label="9600"], ParameterOption [value="19200", label="19200"], ParameterOption [value="38400", label="38400"], ParameterOption [value="57600", label="57600"], ParameterOption [value="115200", label="115200"]]}

same error if i do it as a thing or if i edit the org.openhab.core.thing.thing.json to baudrate 2400

Bridge serial:serialBridge:sensors [serialPort="COM3", baudRate=2400, charset="ISO-8859-1"] 

any ideas or is this a bug in the latest verson?

It’s probably wanting a string, “2400” not a decimal.

Although the docs -

do NOT list a 2400 option, so perhaps it is telling the plain truth.
You’d need to lodge an enhancement request fo the binding.

the weird thing is it was working in 3.2.0 before i went to 3.3.0 …

The problem is caused by the additional config validation introduced in OH 3.3.

The solution to this requires an update to the binding config definition to allow other values other than those in the list.

no worry’s. had not done too much reading on changes to 3.3