Serial Binding sends close bracket after update to 2.3

yesterday I ran the OpenHAB update from 2.2 to 2.3.
Unfortunately, I now have problems with the serial binding, which controls my light control in the house.
Since the update, a ‘)’ is sent to the OFF command, for example:

Switch         L_KG_Flur      "Flur Keller"   		<light>		(gIndoorLight)	{ serial="/dev/ttyIOBox1@115200,ON(!;36;1\n),OFF(!;36;2\n)" } 

If i run

 smarthome:send L_KG_Flur ON
 smarthome:send L_KG_Flur OFF

I get the following logfile entries (linefeed removed):

2018-08-03 08:23:07.529 [DEBUG] [binding.serial.internal.SerialDevice] - Writing '!;36;1' to serial port /dev/ttyIOBox1
2018-08-03 08:23:12.837 [DEBUG] [binding.serial.internal.SerialDevice] - Writing '!;36;2)' to serial port /dev/ttyIOBox1

if i remove the ‘)’ from the item it works as expected:

 { serial="/dev/ttyIOBox1@115200,ON(!;36;1\n),OFF(!;36;2\n" }

maybe someone has an idea why the ‘)’ since the update is sent?


I don´t have an answer, but I can confirm the behavior of the serial binding. Took me 2 hours to find out why my communication to the arduino doesn´t work as expceted.

My current solution: the Arduino filters the ‘)’ fromt the input string.



Triple confirm on this one. Looking forward to a future fix. For the time being I also remove the final ‘)’ from the OFF command in the .items definition. Phew - that debug took a while… :slight_smile:


Any ideas on this one?

16 days ago I’ve made some changes to the serial binding and also to the part where the config string is parsed:

Maybe my changes will already fix the problem. Can you please test a snapshot of the serial binding and report if the problem still occurs?