Serial Configuration Help - Monoprice Whole House Audio (WHA) Binding

  • Platform information:
    • Hardware: Raspberry Pi 4 Model B Rev 1.2
    • openHAB version: 3.0.2
  • Issue of the topic: I am using the Monoprice WHA binding, I have setup the configuration according to the instructions, but I cannot manage to obtain serial connection to the Monoprice 10761.

//serial port connection
monopriceaudio:amplifier:myamp “Monoprice WHA” [ serialPort="/dev/ttyUSB0@9600", pollingInterval=15, numZones=6, inputLabel1=“PA”, inputLabel2=“Kitchen”, inputLabel3=“Office”, inputLabel4=“Master Bath”, inputLabel5=“TV”, inputLabel6=“Phono”]

I have added openhab to dialout sudo adduser openhab dialout in case that was the issue. Also, restarted my RPi and the amplifier. Still no luck. I would appreciate any ideas.

remove @9600 from your configuration.
The serial port interface is configured in the binding itself.
Code snippet:

SerialPort commPort = portIdentifier.open(this.getClass().getName(), 2000);

            commPort.setSerialPortParams(9600, SerialPort.DATABITS_8, SerialPort.STOPBITS_1, SerialPort.PARITY_NONE);
            commPort.enableReceiveThreshold(1);
            commPort.enableReceiveTimeout(100);
            commPort.setFlowControlMode(SerialPort.FLOWCONTROL_NONE);

            InputStream dataIn = commPort.getInputStream();
            OutputStream dataOut = commPort.getOutputStream();

It worked! Thanks for your help.

1 Like