Serious 2.5 Release issues. How to troubleshoot?

Tags: #<Tag:0x00007f4348e7b7f0>

Already have that

Could you be more specific?

It was referred to in this Zigbee issue.

As far as I´m reading this, the changes should have been merged in 2.5 Release…

The Issue was closed but I do not think Chris incorporated it before 2.5 due to other concerns. I just recently needed to work on that for somebody here running 2.5.

It could have made some sense, if it had been merged, as I didnt have the above issue in 2.5M2. But now I have.

Of course you can. Even more useful is to shunt a specific bindings logs to it’s item file. See:

And the “Filter” field at the top of frontail.

I do recommend using tail -f or multitail on a terminal over frontail for over all flexibility. See How to watch and look through logging.

You have full control over what gets logged through many different avenues.

Since frontail is a third party app, you would have to take this to with them.

Not filling an issue does gall but guarantee it won’t get looked at and fixed though.

If you want guarantees, you have to do it yourself.

Well, you’ve given it a shot here. No one in the forum so far has been able to give you any more information. And even if we were, we couldn’t fix it for you. So the next step is to file an issue with the information you do have.

I’m personally not convinced it isn’t working as designed. If it is, the devs will respond to the issue saying so. If it isn’t, they will have a look. But if they can’t reproduce the behavior their setup, their hands are tied. They can’t fix a behavior they cannot reproduce. And there are more than 350! (350 factorial, a number larger than all the grains of sand in the world) possible configurations of OH, which doesn’t count Rules and treats each binding as only one.

You will see bindings reloading every minute, as had been mentioned several times on this thread. You will also see a failed to load binding error log message. This is not what you are experiencing but it is a common problem a number if people experienced when they upgraded and didn’t notice the warning that the rest API docs moved.

Thanks. I already know how to log to a specific file. But in this case, I´ll need to log those involved bindings, which in my example is at leat three (four) bindings.

Filter option in frontail wont work cause it´s specific. Again this example involves 3(4) bindings, which is why its impossible to use the filter option.

I´ll have a look at the link on how to watch and look through logging. I wasn´t aware of other options as mentioned above.

I didnt ask for fix, but suggestions on how to troubbleshot…

They may have suggestions or ideas, even though they cant reproduce… Remember, they know the codes, I´m just a user knowing nothing of whats behind.

I know… thats why I said, this is highly complicated, and why I searched for suggestions on how to trobbleshoot this one.

I know all this… This is not just on the first startup after updating. This issue I can reproduce all the time, since I updated OH to the latest release.
I´m 99% sure, this is not the way it´s suppose to be, (I can be wrong). I´m possisitive something have gone wrong somewhere. I just need to figure out, how to present this without it beeing too complicated and having the manitainers saying “sorry we cant fix your problem, cause we cant reproduce”. I know I have to file the issue. I just want to file something usefull for them to work with.

The behavior is exceptionally simple to describe. Installing/uninstalling an add-on causes the following bindings to reset: (list of bindings). If they need more information they will ask for it and if you don’t know how to get the info they will tell you.

Yes, thats the simple way to do it. But as usual I´m trying to be as specific and provide all the info I can. Guess I should just get that idea out of my head…

Btw… It only happens when install/uninstall bindings from PaperUI. Not doing manual installs in the addons… Also it doesnt seem to be concentrated on Zigbee binding alone. I just tried uninstall Chromecast binding, and the very same thing happened. I assume this happens with all bindings. But only the same 3(4) bindings gets affected.

Actually - I´m close to give it all up… Just had a major hell here.
In a try to get closer to something usefull information, I noticed I had 29 apt updates available. I went into openhabian config and started the update… (when things aren´t working, do something)…
After these updates, things started to fall down on me… First restart of OH went almost fine, except half of my system never came online. I stopped OH, clean cache and restarted again… This startup procedure went fine for a few seconds, then OH looked like its simply froze. Nothing more happened. But OH was still running, cause when I use cli to stop it, I could see in the tail log, that it was stopping the services…
Gave it yet another try - Same thing happened.
Then I ripped of my Rpi, removed devices I´m not using (a Zigbee shield on the GPIO interface). Started again - Same thing happened. Stopped OH, clean cache and rebooted… Finally it looked like is was at least starting again.

I am getting sick and tired of spending lots of hours on this ever day and simply getting nowhere.
Even that damn emphesis is flooding my log with errors at startup (from clean cache) even though I have it setup in PaperUI as I´m suppose to :rage:

Going from a unstable version to a stable version, should not result in an even more unstable system! For some reason, thats what I´m experiencing!

Did I miss something or has Pushover (action) been changed or is this just yet another unexplained issue on my system… Since yesterday my rules containing pushover send message suddenly no longer works. This is the error I get:

2020-01-06 17:59:00.545 [ERROR] [ntime.internal.engine.RuleEngineImpl] - Rule 'Send besked hvis nogen er ved døren': The name 'sendPushoverMessage' cannot be resolved to an item or type; line 8, column 3, length 86

I havn´t touch the rule at all.
This is the rule given the above error. I have several other rules which uses Pushover, given the same error:

rule "Send besked hvis nogen er ved døren"
when

	Item Node13_AlarmBurglar changed from OFF to ON

  then
    if(kimsPhone.state === OFF)
  sendPushoverMessage(pushoverBuilder("Der er nogen ved hoveddøren!").withSound("none"))

end

All I did yesterday was to update all apt´s available. Since then, the above error.

EDIT - uninstall and reinstall pushover does not change anything. (except it resolve in the same error as install/uninstall other actions/binding like descriped in the first post.

EDIT again - As another frustation act, I went into openhabian-config and ran the update to latest stable again. Though it didn´t install anything new, after OH restarted Pushover works again…

This is really odd!!

If something like that problem with the Pushover problem occurs again, log into the karaf console and run:

bundle:list | grep -i pushover

Obviously, replace the “pushover” with the name of the add-on you are having issues with.This will definitively show whether or not the add-on is installed or not, whether it’s active, and whether you may somehow have two versions installed.

I suspect that the update fixed it because clear the cache is part of the update process, though if there was no update to openHAB from apt there wouldn’t have been even that much.

I can’t explain the behavior or give any further recommendations until/unless it happens again.

Good idea… I just saw that the action was installed in PaperUI, which is why I uninstalled it and installed it again. Unfortunatly that did change anything untill I ran the update from openhabian-config…
I´m not sure the update clear the cache, cause when OH restarted, I saw no sign of everything beeing reinstalled like it used to after a clear cache.

I have a similar problem with the telegram action. The sendTelegramMessage isn’t resolved error’s in log. But a few time after startup same rules works find and send.
From my point of view it seem’s so, that the actions are not ‘started’ when first rules are triggered.

That could be the case. For Telegram though, there is now a v2 Binding that provides the Action now. I suspect the separate Telegram Action would be considered deprecated at this point. Perhaps that would address the issue for that service at the least. Doesn’t help with Pushover though.

I have no better ideas anymore than to try something drastic.

In a thought of this specific issue, and some of my previous issues, could be due to beeing hardware failures, I´ve just bought a Rpi 4B (4gb ram version) I´ll setup from scratch, which will be installed on a new SSD as well, (I know, I cant USB boot on the Rpi 4 yet. I´ll have to live with boot from SD card and move root to USB).

This way, any chance of this beeing a hardware (Rpi/SSD) issue should be eliminated, hopefully!
If the issues still appear, I have four Rpi´s for sale, cheap! :smiley:

If you go down that path try to be deliberate and avoid doing too much all at once. For example, install and migrate stuff for one binding at a time. That will help isolate the problem more easily if it turns out to be a problem with the configuration.

I will… In some situations I´ll have to, cause I´ll have to disable my “faulty” system, and then install the same configuration on the new system one by one anyway for the physical devices like my zwave dong, RS485 dongle etc…

Some good and some bad news from here…

I order to reinstall my system on the Rpi4, I first started adding the bindings one by one… No issues at all. Then I started to add the services, all went well untill I installed the Google Cloud Text-To-Speech (under voice menu). Then the same issue started again. (Netamo going offline and a few seconds after online again).

To make sure it really is caused by the Google TTS, I uninstalled this service, and started to uninstall/reinstall several other things… No issues at all.
The I installed Google TTS again, and again the issue is back as soon as I install or uninstall something from PaperUI, actions, misc, persistens no matter what I install from PaperUI, this issue appear when Google TTS is installed.

So the bad news is, I can reproduce this issue, even on a fresh setup using new hardware.
The good news is, its has to be a combination of the system with the Google TTS somehow.

I guess it´s time to file a issue now.

EDIT - HMMPRF! Dont know why, but I just had a idea… Having the Google TTS uninstalled, I installed Habmin… Then the issue came back :rage: Unistalled Habmin again, and the issue seem gone again.
Guess I need to dig deeper into this one.

This is driven me nuts here… Something is very wrong… :hot_face:

I can reproduce the issue when installing the Rest Docs as well, and without the Rest Docs, the issue seems gone… BUT! I know for sure I could install Rest Docs without this issue, cause I did it last night when I started to reinstall on the new Rpi4. And it didn´t reproduce the issue at that time…

So I´m back to nothing clearly again, except I can reproduce the issue for sure when installing:
Google TTS
Habmin
Rest Docs.

Without these, the issue seems gone.
But I havn´t tried every other actions, bindings, Misc, Persistence, Transformations, UI or Voice. Only some of them.

How the heck do I file an issue from this. And which repo is a issue like this suppose to be filed under?
Any advice @rlkoshak or others??

You say that when ever you “install/uninstall a binding, bindings X, Y, Z all appear to restart. This behavior appears to only occur when bindings A, B, C are installed.”

Let the developers ask for more information if they need it.