Server 500 error

Hello all,

It ran before, and it doesn’t anymore… No idea what’s happening.

Installed by apt, updated/upgraded to the last nightly built, on a debian system. After I did it stayed on the ‘installing ui’ page for a while, and now it is back to the error it had before:


Problem accessing /start/index. Reason:

Server Error

Caused by:

at java.lang.String.replace(
at org.openhab.ui.dashboard.internal.DashboardServlet.serveDashboard(
at org.openhab.ui.dashboard.internal.DashboardServlet.doGet(
at javax.servlet.http.HttpServlet.service(
at javax.servlet.http.HttpServlet.service(
at org.eclipse.jetty.servlet.ServletHolder.handle(
at org.eclipse.jetty.servlet.ServletHandler.doHandle(
at org.ops4j.pax.web.service.jetty.internal.HttpServiceServletHandler.doHandle(
at org.eclipse.jetty.server.handler.ScopedHandler.handle(
at org.eclipse.jetty.server.session.SessionHandler.doHandle(
at org.eclipse.jetty.server.handler.ContextHandler.doHandle(
at org.ops4j.pax.web.service.jetty.internal.HttpServiceContext.doHandle(
at org.eclipse.jetty.servlet.ServletHandler.doScope(
at org.eclipse.jetty.server.session.SessionHandler.doScope(
at org.eclipse.jetty.server.handler.ContextHandler.doScope(
at org.eclipse.jetty.server.handler.ScopedHandler.handle(
at org.ops4j.pax.web.service.jetty.internal.JettyServerHandlerCollection.handle(
at org.eclipse.jetty.server.handler.HandlerWrapper.handle(
at org.eclipse.jetty.server.Server.handle(
at org.eclipse.jetty.server.HttpChannel.handle(
at org.eclipse.jetty.server.HttpConnection.onFillable(
at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(
at org.eclipse.jetty.util.thread.QueuedThreadPool$

Any ideas?

Hi there,

i am facing the same problem. I restarted my pi after including some devices and defined some new things in the sitemap, that’s when the problem occurred. Unfortunately changing the sitemap to an older backup did not solve the problem …
Openhab itself seems to run fine, from the android app i can toggle switches.

If you @DQX say: “It ran before, and it doesn’t anymore… No idea what’s happening.” did you also restart your server?


Hello all and @DQX,

this is the same error as here:

and it is solved here:

some more informations can be found here:

and here:


I only had time to work on this again tonight.

After updating my whole computer failed to start, so instead of trying t fix it, I just reinstalled the lot. Let’s hope things don’t break anymore, I have had quite some issues I have to say. Hope and pray…