Setpoint for heating not working in KNX2

some months ago i migrated to OH3 and KNX2. Everything worked without problems - I thought :wink:

This week I noticed that I can change the target temperatures for the rooms, but they always reset after a short time. This has worked in KNX1. I’ve checked the busmonitor in ETS and recognized that a change on a setpoint item does nothing on the KNX bus

I thing i’ve done something wrong, but i don’t get my mistake…

Hardware is a MDT KNX Interface as TUNNEL, MDT Heatingactuators and temperature sensors in Berker switches.

Konfiguration Things (only for one room):

Bridge knx:ip:bridge [  
] {
    Thing device generic [
    ] {
        Type number : Temperatur_KG_Buero        "Temperatur Büro"        [ ga="<3/2/0" ]
        Type number : Temperatur_KG_Buero_Set    "Solltemperatur Büro     [ ga="3/2/1+<3/2/4" ]


Number:Temperature    Temperatur_KG_Buero         "Temperatur Büro [%.1f °C]"        <temperatured>    (gTemperaturen, gKG_Buero)     ["Measurement", "Temperature"]    {channel="knx:device:bridge:generic:Temperatur_KG_Buero"}
Number:Temperature    Temperatur_KG_Buero_Set     "Solltemperatur Büro [%.1f °C]"    <heatingc>        (gTemperaturen, gKG_Buero)     ["Setpoint", "Temperature"]       {channel="knx:device:bridge:generic:Temperatur_KG_Buero_Set"}


Text item=Temperatur_KG_Buero 
Setpoint item=Temperatur_KG_Buero_Set minValue=14 maxValue=25 step=0.5

Can someone give me a hint here?

This is a number type channel.
You’ve linked it to …

which is not a (plain) Number type Item.
When you send commands, it has units (°C) as part of the command, which the binding cannot handle.

1 Like

The KNX from the community marketplace can.

I’ve tried this but was confused about undefined state after saving the items. Thanks for support!

How to use the marketplace in OH3? In OH2 it works over PaperUI. In MainUI i couldn’t find it…

The setting for the temperature now works. But the input reacts very sluggish and also the return values come partly very late or only after a manual reload of the page (BasicUI).

Is this related to the device setting readInterval=3600? Or is this only the case for me?

It‘s available in OH 3.2 Milestone 3. If you use 3.1, you can download the file linked in the forum (category marketplace/bundles), drop that in the addons folder and start it with feature:install smarthomej-binding-knx on the openHAB karaf console. Don‘t forget to uninstall the distribution binding before.

1 Like