Setting up openHAB2 from scratch

Where do I change package=expert.

i followed your link and scrolled down to the openHab Demo Server link.
That takes me to a page with four things to select. “REST API, HOME BUILDER, HABPANEL, BASIC UI”. I clicked them but I don’t understand what they display. I can’t find any explanation. At the bottom there is a link , "Getting started? Please refer to the online documentation. "
That takes me to a page that I must have read 20 times. Paging through the sequence of 5 or 6 pages I get to “Installation” which I have done many times also.

When I put in my IP:8080 I don’t get the page described here:


I get what I described in my first post.

I did a lot of blundering around and stumbled on:
http://docs.openhab.org/v2.1/tutorials/beginner/configuration.html
But as I said the menus don’t match my installation.

Your initial statement was you missed the “Initial Setup” page. I tried to explain how you may fix this:

That answers:

From your further statements I think you are missing PaperUI, the main configuration tool for openHAB.
If you initially chose the wrong package, this happens.

Again, please set your package to expert in your addons.cfg and restart openHAB.

Those are the old docs. Although that page you referred to is still valid: it shows PaperUI. As you are missing this in your setup, you need to change you package :grinning:

After you get PaperUI running please proceed with all the steps you find at:


Install your bindings, add your Things, create Items, link Items to Channels, …

I don’t have any “Install your bindings, add your Things, create Items, link Items to Channels,”

I saw a tutorial that said I could make my cellphone a “Thing” so I decided to install OpenHAB and at least learn from that.

I’m sorry, I was not specific enough. When I typed in my URL:8080 I did not get a start page to select a level of “Simple, Standard…”. It went directly to a page with HOME BUILDER, HABPANEL, BASIC UI, PAPER UI" and a link for "Getting started? Please refer to the online documentation. " which takes me to the 5 or 6 pages that show me all the wonderful stuff I can do…if I only knew how to do them. I follow the pages to the Windows installation. There is a link to a youtube that is totally out of date but further down I see, "Please proceed to the UI Page which gets me to The Paper UI, Basic UI, Classic UI.

Please remember I am trying to just get SOMETHING working. But I keep getting all these overviews, and descriptions of all the things OpenHAB can do. No, “Just do this”.

So, at the bottom of the page there is a link to:

I think this is the Paper UI you want me to follow. I did and installed the Network Binding.
Then had it search. It found nothing so I manually added the URL of my cellphone and sure enough it shows in Things and is ONLINE (with a green background for the text). I then set Item Linking to Simple Mode and Saved.

Now things go to pot. I go to Configuration> Things, click on my phone, and instead of Channels, “Online”, and “Time”, I have “Online”, “Latency (ms)”, and “Last seen”. I have tried all possible combinations of the buttons…Note, the text calls them Radio Buttons" but that is wrong. Radio buttons don’t allow multiple selections.

Anyway, going to Control, the tutorial shows John’s Mobile is, “Online” and “Time 10”.
Mine shows my phone is not online, Latency is -NaN and Last Seen is -.

Where do I go from here?
I don’t have a z-wave stick. I have a SDR and can access many house sensors but I can’t find an SDR binding…although I admit I don’t know what I am doing.
What can I do from here?

Hello Pete,

the above documentation is outdated, lots of things happened in the meantime.
You are right, instead of “Online” and “Time”, the channels are now called “Online”, “Latency (ms)” (the maintainer just changed the description as it’s exactly the same) and “Last seen”.

Where you are not right is your interpretation of the radio buttons: you don’t have to try different combinations in order to get it working. You can chose which information you want to see on the “Control” page, so each of the three channels and their radio buttons are independent.

But let’s take a step back: you wrote that, while running the discovery, you didn’t see your phone listed.
openHAB scans the local subnet, so all devices replying to a ping request will be listed. Is your phone located in the same subnet as openHAB? Have a look at your phone’s IP address and subnet mask and compare it to your openHAB network configuration.

Are they located in the same network?

Regards, Christian

BTW: if you don’t have Z-Wave devices, you won’t need a Z-Wave stick. What is SDR? Never heard of it…

You need to start reading the basic docs to understand the concept of Things, Items, Channels, openHAB is not “point, click, shoot”:




Christian,
Thanks for the response. I will have to look into the subnet issue. I assumed that, since Configuration>Things indicate my phone is “Online”, I was meeting all the criteria.

As for SDR, sorry, it stands for Software Defined Radio. For me it is a $30 USB stick that, with appropriate software, allows me to tune to various radio signals. My home has many wireless security devices. Door sensors, window sensors, CO sensors, Heat, Smoke, Glass Break, etc. I used my SDR setup to decode the messages these devices send. I hope to build a security system that will alert me via text messages. email, voice call…whatever, when any of the sensors are tripped. OpenHAB is one of the methods I am considering. But it sure has its growing pains.

As for Radio Buttons, no big deal but the page has a checkbox. Wikipedia explains the difference:

Thanks again,
Pete

sihui,
I have read those docs or maybe some older versions. I read all the ones I am led to by the links from the “Online documentation” start page.
At this point, to understand the information I am trying to implement something…anything that I can relate to. Too bad there isn’t a “point, click. shoot” for a beginner to start with. Ii thought the Demo might be that but it seems to be obsolete.

Thanks,
Pete

Choose package demo at your initial setup or later by changing your package selection in your addons.cfg.

OK, I see, but the (wrongly used, I see that now :slight_smile:) radio buttons only trigger the channel to be shown on the “Control” page.

You could try to just ping your phone via the command line. If it doesn’t respond, unlock your phone, maybe it has gone to sleep and you’re having the problem the guys in this thread have:

If it still doesn’t respond, then it must have to do something with your network

Ping from the windows command line works fine.
That link seems to be heavy into iPhone, RPi, linix.
That is a long way from Windows and Android phone.
But, without a doubt I need to get into RPi.
I just saw a good deal on a whole kit so I ordered it.
Maybe have it by the 14th.
Now to learn linix.
I did some UNIX work over 30 years ago. I doubt I remember much more then cd…
Until then I have been following sihui’s link.
Looks like I have a lot of work “network share”, UNC paths, mount a drive. Yech.
Oh, IP:
Phone 192.168.1.68
'puter 192.168.1.77

You may have a look into:

Could you please post a screenshot of your item configuration? Click the edit button on top of your phone thing

grafik

I believe this is what you asked for.
Thanks

No, I meant the configuration screen after you click on the crayon icon = edit button

Ah, I was just wondering why your channels have the string “servicedevice” in it. Is it possible that you added your phone with the “Network device with running service” option instead of the “Pingable network device” option? You would need a running service like a webserver on your phone in order to make it work.

Please try to remove your phone (trashcan icon on your screenshot) and add it through the “Pingable network device” option: Inbox -> Search for things -> Network Binding -> Add manually -> Pingable network device; then enter your phone’s IP address

OK, I deleted my phone and used pingable this time. Now I have the first image below. Then I went to Control and I get the second image. Recall, I really don’t know what I am doing. I was just stepping through a tutorial (that I think was obsolete) tying to reproduce the screens in the tutorial. As I recall the tutorial showed the phone was Online but mine shows not Online.

Is there anything useful that I can do at this point? Can I get more experiance with OpenHAB while I wait for my RPi? When that arrives I may be out of commission while I try to get the system set up.

Could you please do that now?

One more thing to clarify: you run openHAB on your Windows machine, right? And you are able to ping your phone from the machine openHAB is running on, right?

Hi, i am looking for how to do with that wonderfull tutorial do to autostart openhab. I do ./star.sh but when i push ctrt+c or do some changes on my “home.rule” the openhab service stoped

:persevere:

Hi, i know this is an old post but need help. I just started learning openHAB.

I am facing the same problem as PeteC faced. I did all as per the tutorial… I run my openHAB on window machine and am able to ping my mobile (android) from this window machine. But in Inbox-> Network Binding -> Search no Thing is found. Neither my Mobile nor any other pc under the same network.

IP of my openHAB Computer is 192.168.20.150
ip of my Phone is 192.168.20.151

Also there are other computers on the same network but none is being found.
If I add manually, it shows my phone always online even if I placed the phone under Airoplane mode/or its wifi off.

Can you help?

Maybe it’s an issue with the Windows firewall? Did you try turning it off? If it works without the firewall enabled, you can try to allow the openHAB process explicitly through the Windows firewall