Setting up openHAB2 from scratch

tutorial
openhab2
setup
Tags: #<Tag:0x00007fe05313b948> #<Tag:0x00007fe05313b740> #<Tag:0x00007fe05313b600>

(Rich Koshak) #21

It’s all the same. Same strategies, same way to assign Items to strategies. In fact, the OH 2 docs right now just point to the OH 1 wiki.

When I migrated I didn’t have to change one character in my .persist files.


(Christian Hailer) #22

OK, I added the persistence service step! :slight_smile:


Switching from FHEM to openHAB 2 - What to expect?
(Pierre) #23

Hello Community!

DocFraggle, thank you very much for this tutorial!!! I am new to openHAB, in this help me to understand what happens under the GUI!


(Roger) #24

Can I pay one of you to port my openHAB 1 to 2? :joy: But yeah, I mean it :grimacing:


(Chris Erasmo) #25

Thank you man… this is really helpful i learn a lot and understand it very well especially I am a beginner on openhab2. I am looking forward for the continuation of the next part of this tutorial.

Cheers mate.


(rsaanon@gmail.com) #26

Great tutorial! But still missing something. In the tutorial, you mentioned configuring z-wave, but there was no mention of a Z-Wave Controller (physical hardware) that was installed. I’m just starting out with OH/2, in general. So please pardon my ignorance.

Wondering if the following setup is possible:
Raspberry Pi + OH2 + Smartthings Hub (that acts as a controller for all Z-wave devices)

-rsa


(Amir Ali) #27

I am trying to find any documentation which have some example how-to use MQTT, Arduno on Openhab. There is lot of videos on youtube but no description how they build there project. If I can get a link on tutorial then I can start my project.

AA


( ) #28

(Andi) #29

Hi,
thanks for the tutorial. I’ve started using OpenHABian and followed the beginners tutorial in the docs. But I am a little bit confused if I should configure things in Paper UI or in textfiles to also have it available in the Basic UI.

I configured Philips Hue in Paper UI. Works great, easy to configure. Then I wanted to adjust my sitemap for basic UI. Do I really have to configure everything again textbased (.things file, .items file and .sitemap)? Because if I do that these configs also affect the Paper UI and I will see i.e. the Hue Bridge twice. Also the lights which I configure are visible again in the other tab in Paper UI.

In my opinion the things and items are already configured through Paper UI - I only want to have it visible in Basic UI. What did I misunderstood here?

Best regards,
Andy


(Ben Clark) #30

Only the sitemap needs to be in a textual format. It can refer to the items that you’ve made in paper UI.

sitemap default label="Main Menu"
{
  Text label="Bedroom" icon="bedroom"
  {
    Frame label="Bedroom Light"
    {
      Switch         item=Bedroom_Light_Switch
      Slider         item=Bedroom_Light_Dimmer
      Colorpicker    item=Bedroom_Light_Colour
    }
  }
}

(Andi) #31

Hmm I thought that I’ve tried that…but now it works!

Thank you!


(Kevin Swanson) #32

I’ve got open hab 2.2 installed. In paperui add-ons have no tab for persistence. Should I have one like in your screenshots or has this functionality been removed?


(Pete Cal) #34

Is there an update to this tutorial? I am trying it and I didn’t get the page with “Simple, Standard, Expert, Demo”. It went straight to a page with "Home, Basic UI, Paper UI, and Habpanel. (Next step of tutorial shows just the first three). I blundered along trying to guess what I should do next to try to follow.

I got to adding my cellphone and I didn’t get to select Online and Time. I got Online, Latency (ms), and Last Seen. When I went to Control My phone shows up but it indicates “Online (not). Latency (ms) -NaN, Last seen -”

I have gone through the tutorial many times in case I missed something but the results are always the same.

Color me confused.


(SiHui) #35

Which tutorial are you referring to?
This one?

You may always change your first choice later by editing your addons.cfg:

# Valid options:
#   - minimal  : Installation only with dashboard, but no UIs or other add-ons. Use this for custom setups.
#   - simple   : Setup for using openHAB purely through UIs - you need to expect MANY constraints in functionality!
#   - standard : Default setup for normal users, best for textual setup
#   - expert   : Setup for expert users, especially for people migrating from openHAB 1.x
#   - demo     : A demo setup which includes UIs, a few bindings, config files etc.
#
# See http://docs.openhab.org/configuration/packages.html for a detailed explanation of these packages.
#
#package = expert

(Pete Cal) #36

I am referring to the tutorial described in this thread.
I can’t get my installation to math the tutorial.

I’ll try to see if I can understand your link.


(SiHui) #37

Change

#package = expert

to

package = expert

and restart openHAB


(Pete Cal) #38

Where do I change package=expert.

i followed your link and scrolled down to the openHab Demo Server link.
That takes me to a page with four things to select. “REST API, HOME BUILDER, HABPANEL, BASIC UI”. I clicked them but I don’t understand what they display. I can’t find any explanation. At the bottom there is a link , "Getting started? Please refer to the online documentation. "
That takes me to a page that I must have read 20 times. Paging through the sequence of 5 or 6 pages I get to “Installation” which I have done many times also.

When I put in my IP:8080 I don’t get the page described here:


I get what I described in my first post.

I did a lot of blundering around and stumbled on:
http://docs.openhab.org/v2.1/tutorials/beginner/configuration.html
But as I said the menus don’t match my installation.


(SiHui) #39

Your initial statement was you missed the “Initial Setup” page. I tried to explain how you may fix this:

That answers:

From your further statements I think you are missing PaperUI, the main configuration tool for openHAB.
If you initially chose the wrong package, this happens.

Again, please set your package to expert in your addons.cfg and restart openHAB.

Those are the old docs. Although that page you referred to is still valid: it shows PaperUI. As you are missing this in your setup, you need to change you package :grinning:

After you get PaperUI running please proceed with all the steps you find at:


Install your bindings, add your Things, create Items, link Items to Channels, …


(Pete Cal) #40

I don’t have any “Install your bindings, add your Things, create Items, link Items to Channels,”

I saw a tutorial that said I could make my cellphone a “Thing” so I decided to install OpenHAB and at least learn from that.

I’m sorry, I was not specific enough. When I typed in my URL:8080 I did not get a start page to select a level of “Simple, Standard…”. It went directly to a page with HOME BUILDER, HABPANEL, BASIC UI, PAPER UI" and a link for "Getting started? Please refer to the online documentation. " which takes me to the 5 or 6 pages that show me all the wonderful stuff I can do…if I only knew how to do them. I follow the pages to the Windows installation. There is a link to a youtube that is totally out of date but further down I see, "Please proceed to the UI Page which gets me to The Paper UI, Basic UI, Classic UI.

Please remember I am trying to just get SOMETHING working. But I keep getting all these overviews, and descriptions of all the things OpenHAB can do. No, “Just do this”.

So, at the bottom of the page there is a link to:

I think this is the Paper UI you want me to follow. I did and installed the Network Binding.
Then had it search. It found nothing so I manually added the URL of my cellphone and sure enough it shows in Things and is ONLINE (with a green background for the text). I then set Item Linking to Simple Mode and Saved.

Now things go to pot. I go to Configuration> Things, click on my phone, and instead of Channels, “Online”, and “Time”, I have “Online”, “Latency (ms)”, and “Last seen”. I have tried all possible combinations of the buttons…Note, the text calls them Radio Buttons" but that is wrong. Radio buttons don’t allow multiple selections.

Anyway, going to Control, the tutorial shows John’s Mobile is, “Online” and “Time 10”.
Mine shows my phone is not online, Latency is -NaN and Last Seen is -.

Where do I go from here?
I don’t have a z-wave stick. I have a SDR and can access many house sensors but I can’t find an SDR binding…although I admit I don’t know what I am doing.
What can I do from here?


(Christian Hailer) #41

Hello Pete,

the above documentation is outdated, lots of things happened in the meantime.
You are right, instead of “Online” and “Time”, the channels are now called “Online”, “Latency (ms)” (the maintainer just changed the description as it’s exactly the same) and “Last seen”.

Where you are not right is your interpretation of the radio buttons: you don’t have to try different combinations in order to get it working. You can chose which information you want to see on the “Control” page, so each of the three channels and their radio buttons are independent.

But let’s take a step back: you wrote that, while running the discovery, you didn’t see your phone listed.
openHAB scans the local subnet, so all devices replying to a ping request will be listed. Is your phone located in the same subnet as openHAB? Have a look at your phone’s IP address and subnet mask and compare it to your openHAB network configuration.

Are they located in the same network?

Regards, Christian

BTW: if you don’t have Z-Wave devices, you won’t need a Z-Wave stick. What is SDR? Never heard of it…