Setting up Xiaomi Mi SmartPlug (Zigbee) with Conbee II and OpenHab 2

I just bought this Xiaomi Mi SmartPlug (Zigbee) for switching mains power and measuring power consumption:

However, I am unable to integrate it into OpenHab. I have two issues:

  1. I was able to pair the device throught the Phoscon web interface as a Light and I am now able to switch it from the Phoscon web app. But it is not found by the Hue binding in OpenHab, when I can for it in the items inbox. I also tried the Deconz binding, but as far as I understand, I need to use the Hue binding for this(?).
  2. The smart plug also has the ability to measure consumption. This was not able to setup at all through the Phoscon web app. I tried scanning for it as a sensor, but was unable to detect it. From Googling this, I got the impression, that it should be supported (which was why I bought it).

My setup:

  • OpenHABian 1.5
  • OpenHAB 2.5
  • Conbee II Zigbee plug with Phoscon setup
  • Everything is running on a single Raspberry Pi 4

So is anyone using these smart plugs? Should they in principle work fully or am I hitting some limited implementation issues?
I would be grateful for any help to help me resolve these issues.

Thanks in advance,

Hi Michael,

I also bought the adapter and have been trying it for a while now. You need the Deconz Binding. Then you need to find out the APIKEY. That’s not difficult, when you know. Just follow the steps here:
Then you manually create a things file. My file looks like this:

Bridge deconz:deconz:homeserver [ host="", apikey="123456AD" ]

And a short time later, the information you want appears in the PaperUi’s inbox.
I am not further yet, I hope it helps you.


@michaelmell Hey, quote from deconz binding site:

“deCONZ also acts as a HUE bridge. This binding is meant to be used together with the HUE binding which makes the lights and plugs available”

That’s mean, you need the hue binding to use plugs with Conbee/deconz. Just follow the instruction on the Hue Binding site.


I’ve just bought the same plug and connected it via a ZigBee USB stick and the ZigBee Binding. I’ve OpenHAB 2.5.10 running. I can switch on and off the plug, but I can’t see any power measurements, even though Amzon describes it to be there.
Do you see the power measurement?

@drhm Dear Heiko,
I cannot comment on this. I had to abandon my smart-home automation ambitions, because I messed up my OpenHab setup and then had to shelve everything due to time-constraints. I am now in the process of restarting this and would be very curious to hear your progress on getting the power-measurement for this plug working. If I get to it before you, I will do my best to update this thread.
Good luck and best,

1 Like

Dear Michael,

thanks for your answer. I’ve asked this question also on Amazon. Two users answered me, that they see power measurements on their systems. But they don’t use OpenHAB.

I’m going to install OpenHAB 3.0 and let you know, if I’ve more success with that version.

With best reagrds,


@michaelmell Dear Michael,

I’ve now successfully integrated the Xiaomi Mi SmartPlug in OpenHAB 3. This was not possible with the ZigBee binding of OpenHAB 2 or 3, but with the help of ZigBee2MQTT. I’ve written down all my steps in this post: Setting up Xiaomi Mi SmartPlug (Zigbee) with OpenHAB 3.



Note: I’m not using ConBee II stick - mine is a CC2531.